3

I'm looking to install QGIS on my Linux/Fedora 21 laptop.

QGIS ver. 2.8 seems to be the new/stable version (Feb. 2016)

What PostgreSQL version should I use with that?

2

2 Answers 2

3

Please check the following link. this might help you. Good Luck

PostgreSQL default values in QGIS 2.8.1

"QGIS 2.8.1, OsGeo4W built against PostgreSQL Client Version 8.3.10,"

1
  • Fedora 21 support, by default, PostgreSQL 9.3.9 / PostGIS 2.1.7 / QGIS 2.6 - I was just wandering if I could install QGIS 2.8, and then wandering what PostgreSQL to put with that. But I think all rather stick with the default versions, for now...
    – Martin
    Commented Feb 3, 2016 at 20:15
1

If you are installing from binaries (rpm), then you should just let the package manager install the recommended version.

If you are building from source, or are just curious otherwise, the absolute minimum PostgreSQL version for QGIS 2.8 appears to be PostgreSQL 8.0, as documented in the build instructions:

Optional dependencies:

  • for postgis support and SPIT plugin - PostgreSQL >= 8.0.x

The 'best' version will depend on your situation. Newer versions may have more functionality or bug fixes, but if you already have an older version setup and running it may be preferable to use it instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.