2

I've just upgraded to QGIS 2.12.3 - and hoped that the issue which was really time-consuming in 2.12. <3 could have been solved ...

On duplicating layer - with tons of joined tables and virtual fields based on complex expressions - any of these virtually calculated fields are lost. This issue is already listed on https://hub.qgis.org/issues/14191 - unfortunately just as bug with normal priority.

I think this feature is essential. are there any workarounds ?

(i know - "Save As" would be a last option. but once more i do not want to duplicate data - which is one of the benefits of join-concept.)

... i have just tried to do "Save Layer as Definition File..." which seems to work fine concerning the virtual fields but (!) did "forget" the label expression i've used and one single table join ..

  • I notice that you have not yet taken the tour which describes how this site works. Here you appear to be making a comment in the area reserved for a question. Would you be able to edit it to make what you are asking clear, please? – PolyGeo Feb 4 '16 at 10:31
  • @ PolyGeo ... could you pls refrain from editing my postings if no policy issues are concerned - e.g. capitalization/upper-casing – robert tuw Feb 4 '16 at 12:40
  • ... and from deleting "practical suggestions" as well - pls ! – robert tuw Feb 4 '16 at 12:42
  • 2
    If you check our tour, you'll notice that improving content and formatting is encouraged by our policies. On a similar note, our policies state that this is a Q&A site only. Feature wishes should be addressed to the relevant software projects on appropriate channels. – underdark Feb 4 '16 at 20:45
  • 1
    i know and really appreciate the overall-policy - but changing things like lower/upper case or punctuation is one step beyond ... and i didn't just ask for additional features but for any kind of workaround solutions - and just in case that there where none of them, to push a corresponding feature request. – robert tuw Feb 5 '16 at 9:00
5

With the next release QGIS 2.14 this will be fixed.

If you have python knowledge, it should be straightforward to port the code linked to above to a small python snippet that copies joins and virtual fields from one layer to another.

Please note that this is not a bug tracker and instead you should raise the awareness on the issue page you linked to, on the developer mailing list or on another communication channel specific to this project.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.