3

I have created a line shapefile from a Garmin gpx track file using QGIS 1.12.3 Lyon. Resultant vector file displays properly with other vector shapefiles. Problem is that created vector file (line shape) will not display over basemaps such as 'OpenStreetMap'.

After additional investigation, I have determined that created line shapefile has the correct projection but it is always overlain by any basemap. For instance, if I set transparency of USATopo map to 50%, I can see the track lines displaying correctly through the map. If transparency is set to 0%, the track lines are blocked, they no longer display. I have moved track line shapefile to the top of the Layer List in the Map Legend and still the tracks are overlain by any basemap. What's really interesting is that labels for the track lines such as name and length display when the track lines themselves do not.

2

This should normally work out of the box.

Make sure that the imported GPX file layer is EPSG:4326 (lat/lon degrees). You can save it to the shapefile in any CRS you want. Please do not use Set Layer CRS in this step.

For the Openstreetmap background, you can use the Openlayers plugin or the new QuickMap Services plugin.

Openlayers requires the project CRS set to EPSG:3857, and On-the-fly-reporjection enabled.

If your vector file lands off the Nigerian Coast, your layer has a wrong CRS.

You can check the data extent with rightlick on the layer, properties, metadata tab. For EPSG:4326 in degrees, the extent should be within +/-180/90.

0

I am answering my own question. I have determined that the ordering of layers in the Layer List Panel does not control layer ordering on the map unless 'Control rendering order' is disabled in the Layer Order Panel. Both panels can be displayed by left clicking on View of the main window's menu then selecting Panels from the drop down menu.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.