1

I am getting following error while working with QGIS2leaf. it saying that QgsSimpleLineSymbolLayerV2' object has no attribute 'brushStyle'. I didn't understand why its coming . Full error what i am getting are as below

An error has occured while executing Python code:

AttributeError: 'QgsSimpleLineSymbolLayerV2' object has no attribute 'brushStyle' Traceback (most recent call last): File "C:/Users/patwardhan/.qgis2/python/plugins\qgis2leaf\qgis2leafdialog.py", line 297, in export2leaf qgis2leaf_exec(self.outFileName, self.basemapName, self.basemapMeta, self.basemapAddress, self.width, self.height, self.extent, self.full_screen, self.layer_list, self.visible, self.opacity, self.encode2JSON,self.createcluster, self.webpage_name, self.webmap_head,self.webmap_subhead, self.legend,self.locate,self.address, self.precision, self.labels, self.labelshover, self.matchCRS, self.selected) File "C:/Users/patwardhan/.qgis2/python/plugins\qgis2leaf\qgis2leaf_exec.py", line 468, in qgis2leaf_exec if symbol.symbolLayer(0).brushStyle() == 0: AttributeError: 'QgsSimpleLineSymbolLayerV2' object has no attribute 'brushStyle'

Python version: 2.7.5 (default, May 15 2013, 22:44:16) [MSC v.1500 64 bit (AMD64)] QGIS version: 2.12.0-Lyon Lyon, cd9d645

  • 1
    do you have a polygon-layer without filling? – Kurt Feb 5 '16 at 5:09
  • yes i guess but its just border layer of canton. i overlapped it to display my address point . should i remove that polygon layer? – suyogpatwardhan Feb 5 '16 at 5:10
  • remove it or convert it to a polyline – Kurt Feb 5 '16 at 9:03
3

qgis2leaf is no longer being developed. See the Github repository at https://github.com/Geolicious/qgis2leaf. The last commit was on 20 April 2015. Use qgis2web instead, which is under active development - https://github.com/tomchadwin/qgis2web.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • i tried with qgis2web its working very nicely. thanks Tom – suyogpatwardhan Feb 5 '16 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.