1

I am doing spatial joins on points and street (line) features to identify the closest street to each point. However, despite getting appropriate distances returned for each points, closest road, the attributes of the identified road, in some cases an incorrect road and it seems to be one road specifically that is favoured. Projections of both layers and the project are consistent and nothing is selected in either layer. Am I missing anything?

Attached image shows features joined with same identified attribute for street, but distances, which are more appropriate to the points highlighted.

enter image description here

And the parameters for join...

enter image description here


Just to clear this up - the dataset I was using had been modified by others adding in extra features, which seems to have introduced my problem. I'm not sure why or how exactly, but going back to the original set with no extra features returns the results I would expect.

closed as off-topic by PolyGeo Sep 17 '16 at 9:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This problem cannot or can no longer be reproduced. Changes to the system or to the asker's circumstances may have rendered the question obsolete, or the question does not include a procedure to enable potential answerers to reproduce the same symptoms. Such questions are off-topic as they are unlikely to help future readers, but editing them to include more details can lead to re-opening." – PolyGeo
If this question can be reworded to fit the rules in the help center, please edit the question.

  • A screenshot of your spat. join parameters may be helpful. – Jyler Feb 5 '16 at 17:06
  • Actually, I meant the settings that you chose to perform the join. – Jyler Feb 5 '16 at 17:22
  • Extremely long name for shapefile is sometimes / always bad idea. Try 8 symbols long – FelixIP Feb 5 '16 at 19:34
  • 1
    Have you tried running Repair Geometry on your street or point files? Whenever I run in to weird spatial bugs, I run a repair and try again. I suspect it might be the road layer that needs to be repaired. – CStarbird Feb 5 '16 at 21:41
  • Looks like there is a duplication of results in the highlighted rows. Assuming your in OSGB36 using ITN data. Is High precision on in the geodatabase? – Mapperz Feb 6 '16 at 20:04