2

The thematic legends for ranges are automatically set to the word "to", for example "10 to 20" "20 to 30" etc. I need to write it with a dash instead: "10-20", "20-30". Can I change the default settings somewhere?

3

No, it is not possible to change it like that, but you have some options that might help.

1.

Create thematic map and populate all fields in Customize Legend dialog

enter image description here

Then save this theme as a template with Save Customized Legend Text checked:

enter image description here

and then, when you use this template later, you must check Use Customized Legend Text

enter image description here

Of course, if next time your number of ranges is different (more than you have created in a template) then you have to adjust it manually for those extra rows (it will defaults to to again).

This could be managed if you have several customized templates with more or less defined ranges in it.

2.

Second way would be that you prepare all your thematic legends and save your workspace. Then, open your workspace in your favorite text editor and find set legend commands and change to to dashes.

set legend 
  layer 1 
    display on 
    shades on 
    symbols off 
    lines off 
    count on 
    title auto Font ("Arial",0,9,0)
    subtitle auto Font ("Arial",0,8,0)
    ascending off 
    ranges Font ("Arial",0,8,0)
      auto display off ,
      "0 to 200" display on , <--- replace here 'to' with '-'
      "200 - 300" display on ,
      "300 - 400" display on ,
      "400 - 500" display on ,
      "500 - 86.900" display on  
1
  • Thanks for your help! I tried your second options but I can't find the ranges in the text editor: set legend layer 1 display on shades on symbols off lines off count off title auto Font ("Gram.regular",0,12,0) subtitle auto Font ("Gram.regular",0,10,0) ascending off ranges Font ("Gram.regular",0,10,0) auto display off , auto display on , auto display on , auto display on , auto display off , auto display on , auto display on , auto display on , auto display on , auto display on – Helena Feb 11 '16 at 7:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.