1

I made a mistake regarding coordinate systems and lining up two layers.

I have a raster with elevations in EPSG:2949. I created a point data shapefile and entered about 600 hundred points manually lining up with where I want them on my raster. After adding all those and trying the Point Sampling tool I found that my point data shapefile has EPSG:4326 as it's coordinate system so Point Sampling will not get me an output.

Switching my coordinate system moves my point elsewhere as expected so basically I'm trying to get my two layers (raster and point data) on the same coordinate system while keeping the points where I drew them originally.

Is that possible?

2 Answers 2

2

When you switched the CRS did you do a 'save as' (required to reproject)? If you just changed the CRS in the layer properties you won't actually reproject and will see features moving. If this is the case, you'll need to first set the CRS back to the original in layer properties, then do the 'save as' to reproject to your desired CRS.

0

Probably not the best method but something similar happened to me a while ago and the way I resolved it was to:

  1. Resave your point layer with the Save As... option, as mentioned by @SpatialSuccess

  2. Toggle the Edit button for your point layer, select all points either manually or using the Field Calculator

  3. Click the Move Feature(s), select and drag one point (all points will also move relative to each other) and align the selected point to the relevant location above the raster.

This is assuming your raster isn't located too far from the points otherwise there may be a lot of scrolling involved (which can be a bit of a drag).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.