2

I have road data and my goal is to get rid of any data where intersections are. That way when two road features meet they do not intersect. I am using FME from safe to complete this.

not what i am looking for

what i am looking for

I tried using a "areaoverarea" transformer and create a list from its parameters and then use a "listduplicateremover"to remove duplicate lists that contain features with the same name. I thought this would get rid of the overlapped areas so intersections were clear. So far it has not worked. I was wondering if anyone had any other ideas.

sorry for the crude drawings.

1

You're on the right track using the AreaOnAreaOverlayer. That transformer will create an attribute to store the number of overlaps. You can just filter anything that is greater than 1. enter image description here

Another thing you could try is to use the Intersector transformer. Output the nodes and buffer them. Then delete the node buffers from the buffers of the centrelines. Note, the intersector also has an Overlap Count Attribute. So you may want to make use of that as well.

  • So before I do this step I buffer the lines to get them to appropriate size based on road size. Then I did those steps. It works but in some instances where it cuts the roads its kinda makes the end weird shapes or has slivers that stick out and sometimes when the roads meet at right angles it doesnt cut out the entire section it leaves a small square above where they meet. – Kyle Kouri Feb 12 '16 at 16:58
  • You'll have to suit this process for your own workflow. Perhaps edit your question to indicate that all of the roads have different buffer sizes. Also include additional screenshots of the problems you're having now. – Fezter Feb 14 '16 at 23:46
0

@Fezter Sorry for the late reply. Yes I see that is my issue. Yes based on road classification of HWY, city street, Freeway, ect I am buffering the roads at different widths. My work bench starts with a line joiner to take different road segments and combine them. The original segments were broken up in odd spots. Once the segments go through the buffer i use the areaoverarea. These are the issues I am having: first iif a road meets at a non 4 way some of the buffer is preserved and it is not a clean cut at intersections. see attached image. Error on roads

I am also getting a similar error where road widths are different. I thought about trying to use a snapper but still no luck. I may be using the wrong settings in it, but not sure what correct ones would be.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.