Editing in Desktop standard 10.3 and I am having issues with snapping polylines. I keep getting the same error below when I try to snap or move a line. Any ideas On why this might be happening?

enter image description here

1 Answer 1


You might try creating a very large feature (larger than the entire layer) and then deleting it. That worked for me recently but if you can't create that large feature (because of the same error) try these steps.

You may also try to do your editing in a new MXD (surprisingly this has fixed editing issues for me recently). Here was the (somewhat unrelated) problem that I had. What can I do when snapping doesn't work correctly?

This reference is outdated but I think it still applies. reference: http://support.esri.com/cn/knowledgebase/techarticles/detail/12602 see also: "The coordinates or measures are out of bounds" when converting labels to annotations

  1. Right-click the problem feature class from ArcCatalog and click Export > Geodatabase to Geodatabase.
  2. Navigate to the output Geodatabase location and type the name of the new feature class
  3. Click the Change Settings > Spatial Ref tab > Change.
  4. Click the X/Y Domain tab and update the extents to accommodate the new data you wish to add.
  5. Click OK on the 3 dialog boxes to initiate the export.
  6. If using an SDE Geodatabase, right-click the new feature class to register it as versioned before returning to ArcMap to edit.
  7. Verify the new feature class extents in ArcMap by right clicking the Feature Class > Choose Properties > Source tab.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.