I got a GIS Data-set for swedish cities. The problem is that they have strange names such as:





Did someone have the samoe problems? I think "ö" for instance mean "ö" for example - but I am not sure if there is a system behind that.

  • What format is your data in (Shapefile, FileGeodatabase, KML, etc)? What software are you using to work with it (QGIS, ArcGIS, etc)? – Radar Feb 12 '16 at 21:54
  • 3
    Have you tried to set the Character encoding to UTF-8? – Skye Feb 13 '16 at 1:29

this is definitely an encoding problem. figure out what your normal encoding type is. since you're talking about Swedish names, it's probably utf-8 (as @Skye already proposed in his comment) with character setting ISO-8859-1.

you should first:

1) try changing the encoding of the specific shapefile with the messed up characters ideally by using OpenOffice (see link below), or in case 1) doesn't help:

2) change your general settings of qgis usually under C:\Programs (x86)\Quantum GIS Lisboa\bin. this should only be necessary if you're using an older version of qgis. be careful with this, since it might affect other shapefiles you import. the following post about German characters explains how you'll be able to do this exactly:

How to display special characters German "ÄÜÖß" in a map?

Not the answer you're looking for? Browse other questions tagged or ask your own question.