2

Every time when I start my QGIS I see the following message:

GRASS init error: Problem in GRASS initialization, GRASS provider and plugin will not work : Module built against version $Revision: 64733 $ but trying to use version $Revision: 67364 $. You need to rebuild GRASS GIS or untangle multiple installations.

This problem has appeared on Friday. And I am not able to find out what caused this issue. I work in Ubuntu Trusty Tahr 14.04 LTS. QGIS version is 2.12.3-Lyon.

Could someone help me to solve the problem with QGIS and GRASS?

  • I can confirm that this error also occurs on Ubuntu 15.10 – Paul Shapley Feb 17 '16 at 22:32
  • I had to uninstall GRASS using apt: sudo apt-get remove qgis-plugin-grass – Eugene Kluichnikov Feb 18 '16 at 10:15
  • Have tried the nightly versions of QGIS and Grass71 but still displays the same error. No such issues with the same installations from 'Osgeo4w' on Windows. – Paul Shapley Feb 20 '16 at 15:39
  • This problem is also occurring in LTR version 2.18.27. – Sergio Jan 19 at 12:42
1

According to

https://lists.osgeo.org/pipermail/grass-user/2016-February/073655.html

... "QGIS was built against a earlier version of GRASS." They suggest to use the nightly builds of QGIS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.