3

The CRS on all three layers are the same. I have tried deleting the PRJ file and reloading. I have also tried Vector> geometry tools> check validity with no errors.

![this the shape file, the purple dots are my data there are 2 other files lines and text]1

so when I zoom in the dots disappear

9
  • I don't think you missed it but its worth a shot: Is "scale dependent visibility" checked in the general tab of the properties? Some sources like OpenStreetMap have this option checked by default.
    – Papierwolf
    Feb 15, 2016 at 12:34
  • 1
    Could you annotate your graphics to show us what you are talking about? Is it the blue blobs on the first plot? Are they hidden under the linework? Can you supply a shapefile that has this problem?
    – Spacedman
    Feb 15, 2016 at 12:42
  • none of the layers have "scale dependent visibility" checked Feb 15, 2016 at 13:18
  • yes the blue blobs in the railway is the layer I have added Feb 15, 2016 at 13:18
  • the second pic is when I have zoomed in showing that my new shape file disappears...I thought I had labelled these. Feb 15, 2016 at 13:20

1 Answer 1

4

According to the metadata for your point layer, there seems to be a problem with the extent:

Extents

In layer spatial reference system units

unknown extent

I believe this is the cause of your points disappearing.

To rectify this, re-save the layer using the Save As... option and select the relevant CRS (which I assume is EPSG:27700, the same as the other 2 layers). You should now be able to zoom into the points:

New point layer

6
  • Export to vector file failed. Error: creation of layer failed (OGR error:Failed to open Shapefile `B_Chambers.shp'. ) Thanks Joesph...when I save as I get this error message and it doesn't create a new file... Feb 15, 2016 at 15:27
  • 1
    @SallyO'Hara - Where are you saving the shapefile? Sometimes it fails because you need permission to write to a specific directory.
    – Joseph
    Feb 15, 2016 at 15:35
  • 1
    Hi Joseph you are right!! I was saving it in a stupid place now it is ok and it is fixed. Thanks very much for that. I'm not sure how you could tell from the meta data though - when I looked from the properties there was nothing listed Feb 15, 2016 at 15:38
  • @SallyO'Hara - Awesome, glad you got it fixed! And most welcome! When you scroll down the properties, the 2nd last section details the extent of the layer which mentioned it was unknown for your "Chambers" point layer =)
    – Joseph
    Feb 15, 2016 at 15:41
  • 1
    @SallyO'Hara please consider to mark the answer as accepted: gis.stackexchange.com/help/someone-answers
    – AndreJ
    Feb 15, 2016 at 17:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.