3

I have create a shapefile using Arcgis 10.3 . the shapefile contains attribute data in Arabic language . the problem came when I open it in Mapwell (an app specializes in creating navigable maps) Mapwell displays it as series of question marks and other symbols , even if I set the encoding to Arabic . Here another I have noticed , When I export the same data using Arcgis 10.0 it just works flawlessly.

I did some workarounds like changing the encoding scheme of some files (.cpg and .dbf) and other things, and nothing has worked

2

Sometimes it happen because of system different language, you can solve display right to left languages character such as Persian and Arabic when you "change system locate..." language in "Region and language" in Windows OS.

  1. Go to control panel
  2. Find Region and Language
  3. Select Administrative Tab
  4. Language for Non-unicode programs and change current Language for Non-unicode program to Arabic.
  5. After that restart your system.

enter image description here

  • Sorry , It doesn't work – salambshr Feb 16 '16 at 11:39
  • Ok I recommend convert ArcGIS output to unicode: open registory editor (type regedit in run) or search regedit.exe in windows folder, after that find and open below address in registry Computer\HKEY_CURRENT_USER\Software\ESRI choose New from Edit menu and select Key, Type "Common" for new key and press Enter create another key inside "common" and call it "CodePage" and then choose "CodePage" and create "string value" change name to "dbfDefault" and then right click on it and choose modify and finally change "Value Data" to "UTF-8" eventually restart your system. – Predator X Feb 16 '16 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.