I've noticed that some SVGs are distorted when outputting to a vector PDF from QGIS. A good example is NorthArrow_07.svg.

The image on the left is how it looks in the composer and the image on the right is the PDF output.


I have tried increasing the composer DPI but it has no effect. Is there a setting that causes this distortion? I need vector output - not raster.


Not sure why that is getting distorted but a workaround is to print it as a raster in the Composition menu > Export settings:

Print as raster

This seems to fix the distortion:



Locate the svg file in your QGIS directory (something like .../apps/qgis/svg/arrows, open it up and save the image as a png. Then use the png in your Print Composer. When exporting to pdf without the Print to raster setting enabled, there should not be a distortion but you may see some degredation in the quality of the image depending on the size.

  • Yes, I was aware of this but I need vector output. Question amended.
    – Damien
    Feb 19 '16 at 0:32
  • @Damien - Edited post.
    – Joseph
    Feb 19 '16 at 10:52
  • I appreciate the workaround but I need 100% vector output. This simple symbol was just an example. My actual maps are full of symbols. I'm trying to eliminate the need for Adobe Illustrator in my day-to-day cartography and QGIS is almost there. Falling back to raster is a bit of a hack in the CAD/GIS world.
    – Damien
    Feb 20 '16 at 10:23
  • @Damien - No problem buddy! Only other alternative I can think of is to Export as Image and then use an image-to-pdf converter. Feel free to send a bug report.
    – Joseph
    Feb 22 '16 at 11:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.