3

I'm using ArcMap 10.2 and I'm currently trying to clip a county-wide DEM layer (.lyr file) down to a smaller area using a shapefile. The data frame coordinates system is set to US Feet which is what I need. The DEM's coordinate system is in meters and I cannot change that. The shapefile I'm using to clip the DEM I have tried both setting to Meter and to US Feet. I'm using the Extract by Mask tool in the Spatial Analyst > Extraction toolbox. Each time I receive the same error message: Output Raster is listed as "empty" (I do have a workspace set up locally) and the error codes I receive are: 010429, 010213, and 010067. I've looked these up but I know I've gotten this process to work before, I think it's more a coordinate system problem than anything.

Here is the error message I've received each time after trying to extract:

error message

I've found and downloaded a raster/DEM that is in US Feet. I've set the data frame to US Feet, and I've made sure the shapefile to mask is set in US Feet. In the "Extract by Mask" tool window, I went into Environemnts and set the Output Coordinates to match the DEM and the Raster Analysis Cell size to match the DEM. The workspace is local and I've tried decreasing the size of the shapefile I'm using to extract (incase it was just too big). I'm still getting the same three errors. From what I can understand, the first error (010429) seems to indicate that arcmap can't read the DEM layer correctly? It doesn't recognize it somehow? I've downloaded and used DEM's from three different providers so I don't think it's a sourcing issue.

  • 2
    I've had raster tools fail while working in an MXD, but work just fine using the same steps in a new blank MXD or in Catalog. Always worth a shot to try out if you're stumped. – Jyler Feb 18 '16 at 18:14
  • I've honestly tried starting fresh in a new MXD several times at this point, I'll give it a shot again though! – Struggling Feb 18 '16 at 18:16
  • IT WORKED THANK YOU SO MUCH!!! New MXD + using raster tools in the catalog instead of the pop up worked? Ive been trying ALL MORNING. thanks so much!, finger's crossed bc i have eight more to do.... – Struggling Feb 18 '16 at 18:22
  • 2
    I've been there too. So frustrating. I'm going to submit my comment as an answer in case anyone runs into this in the future. – Jyler Feb 18 '16 at 19:01
4

I've had raster tools fail while working in an MXD, but work just fine using the same steps in a new blank MXD or in Catalog. Always worth a shot to try out if you're stumped.

2

This can be an issue when you have a project-on-the-fly situation, which cause resampling into your process.

You might want to try working on the environment Output Coordinate System. Try to set input the same information as the raster data your are filling.

Here is the ESRI error code help page to use as reference.

  • I changed the Output Coordinate System to match the DEM I'm working with and I got the same exact error messages. It's a DEM I've downloaded from lidar.salisbury.edu. I was doing the same exact thing yesterday and eventually got it to work - I just don't remember how, and it definitely wasn't this complicated. Thanks for the answer though. – Struggling Feb 18 '16 at 16:48
  • I don't know if it's relevant, but I can clip the DEM via Data Management > Raster > Raster Processing > Clip. However, my next step is the Fill tool under Spatial Analyst > Hydrology and that does not work when I use the clipped DEM as opposed to the extracted DEM. – Struggling Feb 18 '16 at 16:50
  • What is the file type/extension for the clipped DEM? – whyzar Feb 18 '16 at 16:51
  • the clipped DEM is a .tif, i also downloaded and tried to extract an area of a different DEM and I got the exact same error message. So i don't think it's the actual DEM file causing the issue.... – Struggling Feb 18 '16 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.