3

I have a problem related to the distance matrix in QGIS (2.12.0). Instead of meters it calculates distances in degrees. I found that some other users faced also this problem. I tried to solve it according to the instructions given by others. Unfortunately it didn’t work in my case. I don’t know where the problem is.

Regarding project properties, I set enable on the fly CRS transformation and chose ETRS89 / Poland CS92 as my project CRS. For Settings->Options->CRS I chose Automatically enable on the fly reprojection by default; and use project CRS for new layers.

I uploaded CSV file with x,y coordinates (the sample: 52.29685 20.93881 DORYCKA 5, Warszawa). And then saved this CSV as ESRI shp (with project CRS). The objects were visualized on the map.

Unfortunately, as I said, I was able only to measure distance matrix in degrees - is it possible to do so in metres?

2

Look at my setting: enter image description here enter image description here

In this sample your coordinates 52.29685 20.93881 are probably in WGS84 (EPSG:4326) that you need change "use crs" to "ask about crs..." - second screen. I think that you create new shp layer using menu LAYER>Add Layer>Add text Layer csv. After clicking "OK" you will be asked abut CRS. Pick from list WGS84. enter image description here After that the layer will created with original CRS (WGS84). enter image description here Now right click on layer and "Save as..." and pick CRS92. This will convert your layer from WGS84 to CRS92. Nextly open new project with CRS92 and add converted layer. That should do your job.

  • Hello! Thank you for your comments and hints. Unfortunately I was not able to solve my issue... I have similiar settings to yours, Artec. I have also thicked "Enable 'on the fly CRS transformation" in Project properties. I did as you said: 1) uploaded CSV file 2) reprojected layer (in geoprocessing tools) and chose CRS92. 3) I saved this reprojected file as shp with CRS92. 4) I deleted all legends 5) I uploaded shp (CRS92) Distance matrix tool didn't work :( I did it many times, but every time the result was the same... Any ideas what I do wrong? Thanks and best regards, Marcin – martinez Feb 20 '16 at 18:14
  • Marcin, look at my updated answer. If issue still exists share your sample .csv file. – Artec Feb 20 '16 at 19:30
0

It turned out that opening a new project with CRS92 was crucial. I thought that it is just enough to erase a legend and upload a shp with CRS92. Thanks to @Artec.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.