1

http://servername:6080/arcgis/rest/services/xxx/xxx/MapServer?token=xxx

works fine and I am directed to the service information without a need to login

however

when using the mapped (external DNS record) reference, it gets to the ArcGIS REST login page

http://xxx.com.au/arcgis/rest/services/xxx/xxx/MapServer?token=xxx

  • What method are you using generate token? Http referrer, IP request or ip? where is the server? AWS, azure, etc... And where are you making the requests from? – risail Feb 23 '16 at 1:36
  • Do you have access to the logs on the physical server? if so what do the requests you send look like? Could it be that the token is stripped off by some firewall or proxy? – nmtoken Feb 23 '16 at 8:21
  • thanks , I think my main issue is that my public URL domain.com/arcgis/admin does not work (throws up a 404 error) BUT domain.com:6080/arcgis/admin works ok , I can't seem to figure out why it exposes the 6080 port in the URL token seems to work ok when using the domain.com:6080/arcgis/admin but I need it to work as domain.com/arcgis/admin – Vincent Feb 24 '16 at 22:13
1

Like Dan mentioned in his comment, how and where are you generating your token?

I ran into a similar issue with some REST API scripting. I had generated my token at http://localhost:6080/arcgis/admin/generateToken with the Client parameter set to Request IP. When I would try and access secured services programmatically using my public URL and token (much like you are doing), I would get an error for invalid token.

What I had to do was generate my token from the REST admin at the public URL (http://domain.com/arcgis/admin/generateToken), using Request IP, then my token was valid when used in conjunction with the public URL.

  • thanks Chad, I think that would resolve part of my problem. my other issue is that my public URL domain.com/arcgis/admin does not work (throws up a 404 error) BUT domain.com:6080/arcgis/admin works ok , I can't seem to figure out why it exposes the 6080 port in the URL – Vincent Feb 24 '16 at 22:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.