I have a vector layer containing nearly 8000 singlepart polygons. It looks like this: enter image description here

I want statistics on the area that is further than 2,5m away from any border. I thought I could do this by creating a buffer of 2,5m around all polygons, then extracting the buffer area from the original dataset. I manage to create the buffer, but it is not a separate layer, and the polygons that are created are all multi-part with double lines.

When I select a polygon, I see the lines are overlapping, and I need the buffer lines to be separate polygons. I have tried using the multipart to singlepart tool, but it does not solve the problem. Neither does creating a union between the original layer and the buffer layer.

This is one example - here I have selected one polygon in the buffer layer(the original layer behind with grey lines, the buffer layer with see through background ad red lines, selected polygon marked with blue lines):: enter image description here

  • 1
    Have you tried selecting the polygons by using the search by location option? If you are not able to do this directly maybe try selecting the ones that are within 2.5m and then inverting that selection Feb 23, 2016 at 8:26
  • If I could create the buffer as separate polygons I could probably use the search by location, but I think my problems are even more basic as I can even select one singe buffer area by clicking it. I have updated my question to explain the problem better. Feb 23, 2016 at 8:39
  • 1
    Use negative buffer
    – FelixIP
    Feb 23, 2016 at 8:50

1 Answer 1


I think you're on the right track. What I find a bit peculiar is that you don't get a separte layer from your buffer function. Have you entered an output feature class in the tool?

Idea 1: Try the approach by @FelixIP. Negative Buffers might be what you're after.

Idea 2: Another option might be to try to dissolve the buffered polygons (see image below). This should get rid of all the overlapping parts, however, you might loose some detail.

buffer tool

You should receive a separate layer using the buffer tool like this. After that I suggest you try the method proposed by @Hasan Mustafa - select by location.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.