I have a layer with several shapes and from here I want to delete the lines. I tryed Toggle editing and Select features by polygon but when closing the polygon, it dissapears. Also I tried to delete all the nodes that I don't want by selecting them with the Node Tool buton, but nothing happened. What do you suggest me to do?

This is my example: enter image description here

enter image description here

  • Are you sure that you are enabling the edits on the correct layer? Did you try refreshing it? sometimes residual lines are shown for a bit but they don't remain there. Feb 23, 2016 at 10:03
  • Hello, thanks for your answer! Yes, I am on the correct layer. I also tried to close and reopen the project. I added a picture above, so that you can see that the edditing is on. Feb 23, 2016 at 10:16
  • I have checked now, and apparently I can't delete the nodes from the Node Tool in case the shape has less than 4 nodes. Feb 23, 2016 at 10:26
  • 1
    How are you deleting the features? Pressing the Del key on the keyboard or through the toolbar Edit > Delete Selected?
    – Joseph
    Feb 23, 2016 at 10:28
  • 1
    is the layer one feature or multipart? if it's a multipart, try using the delete part in the advanced digitizing toolbar
    – HDunn
    Feb 23, 2016 at 10:29

2 Answers 2


Your shapefile contains a multipart single feature as mentioned by @HDunn. In order to delete separate polygons, you will need to convert this to singleparts by using the Multipart to Singleparts tool:

Vector > Geometry Tools > Multipart to Singleparts.

I ran this and saved the output as "Free space v2.shp". Now you can edit and delete those pesky polygons!

Multipart layer

Multipart layer edited

I noticed there's quite a few of those dangles in your layer. A good method may be to use GRASS's v.clean tool with the rmdangle option to remove them automatically. You can access this from:

Processing Toolbox > GRASS commands > Vector (v.) > v.clean*

I used the following parameters (note the fairly high threshold):


Before being cleaned:

Before cleaned

After being cleaned:

After cleaned

If there are any more polygons you don't want, you can remove them manually as there should be a lot less of them now.

  • You may want to lower the threshold from 100 as it does cut out a number of polygons which look as though they should be kept.
    – Joseph
    Feb 23, 2016 at 14:35

First Make sure that you have enabled editing on the correct layer. Then use the Node Tool to select the nodes you want to delete (right click and drag to create a rectangle and select the nodes) enter image description here Press delete and you are done, don't forget to save your edits. enter image description here

  • Node tool: could not snap to a segment on the current layer. This is the answer that I am receving when I am following your steps. Just this layer is turned on, so then for sure is the right one that I am using for editing. Feb 23, 2016 at 12:04
  • Take a look at this gis.stackexchange.com/questions/120728/… Feb 23, 2016 at 12:12
  • It's probably because your snapping tolerance is set as 0. Feb 23, 2016 at 12:13
  • I have changed it. Even if I select several nodes, they don't get deleted. I can delete the nodes of a line only until I reach at 3 nodes, and from there it does not allow me to do anything else. Feb 23, 2016 at 12:28
  • So you can delete 3 nodes in every line, or in total 3 nodes before it stops letting you do anything? Feb 23, 2016 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.