3

The documentation says that GDAL_PDF_LAYERS_OFF takes a list of comma separated layers. Examples look just like what I am trying to do.

Executing the following gives an error FAILURE: Too many command options.

gdal_translate -of GTiff -co "TILED=YES" -co "TFW=YES" MyTopo.pdf MyTopo.tif --config GDAL_PDF_LAYERS_OFF "Other_5", "Quadrangle_Extent", "Other_2" --config GDAL_PDF_DPI 150

If I only use a single layer to turn off, it works flawlessly. Am I missing something simple?

This was the solution as requested. Double quotes as shown in some examples are not needed.

gdal_translate -of GTiff -co "TILED=YES" -co "TFW=YES" MyTopo.pdf MyTopo.tif --config GDAL_PDF_LAYERS_OFF Other_5,Quadrangle_Extent,Other_2 --config GDAL_PDF_DPI 150

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.