Recently I was learning how to set up qgis server.

So here's the trouble I've encountered so far:

  1. I was using OSGEO Live 5 Distribution ISO' Installed in dual boot mode with windows 7
  2. I got the GetCapabilities work after fresh install. the response was as indicate in qgis server manual, the XML info about layer etc
  3. After I execute update software system, then I tried to do the GetCapabilities returned 500 Internal Server Error.

I didn't do any change in the qgis system which was worked fine before software update.

What should I do to tackle this error

I'm very new to linux or foss, it just my work project have positioned me to like it or not to learn linux and foss.

so I followed up advice I open the error.log have information such as following:

[Sat Dec 24 22:33:54 2011] [error] mod_fcgid: process /usr/lib/cgi-bin/qgis_mapserv.fcgi(1862) exit(communication error), get unexpected signal 6 
[Sat Dec 24 22:33:59 2011] [warn] [client] mod_fcgid: error reading data, FastCGI server closed connection 
[Sat Dec 24 22:33:59 2011] [error] [client] Premature end of script headers: qgis_mapserv.fcgi 
[Sat Dec 24 22:34:05 2011] [error] mod_fcgid: process /usr/lib/cgi-bin/bik/qgis_mapserv.fcgi(1864) exit(communication error), get unexpected signal 6 
[Sat Dec 24 22:35:10 2011] [notice] caught SIGTERM, shutting down

what the information state and a follow up action to take to troubleshoot the error.

I also attached a link to the error.log file http://www.mediafire.com/?3zeuz48eeu8g8v1

  • Start by looking at the logs. They usually are stored in /var/log. That should give you more information as to what is not working and hopefully provide pointers.
    – unicoletti
    Dec 26, 2011 at 21:43

2 Answers 2


I had this exact problem recently. Not saying that this is best solution but it worked for me.

For me getcapabilities at http://domain.com/cgi-bin/qgis_mapserv.fcgi?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities would give internal server error and same errors as you in apache2 log.

I created a directory in cgi-bin call map and symlinked qgis_mapserver.fcgi and map.qgs and with following link getcapabilities works as does the map server.



I had the same problem, even 6 years after, so here is the solution which worked for me. QGIS-Server needs a virtualframebuffer running, so installing and running xvfb helps. The steps are described here : https://www.itopen.it/qgis-server-setup-notes/ (and then start the server with "/etc/init.d/xvfb start").

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.