1

I am using ArcGIS 10.1. I have a polygon that won't label zoomed out beyond 1:150,000. I am using the Maplex Label Engine. When I switch the Date Frame to the Standard Label Engine the label shows. However, I need the label offset of my feature by about an inch with a leader going to it. There is no Reference Scale in the Data Frame Properties. The Scale Range for the layer is set to 'Show layer at all scales'. The Labels Scale Range is set to 'Use the same scale range as the feature layer.' My label Method is 'Label all the features the same way.' In my Placement Properties under the Conflict Resolution tab 'Never remove (place overlapping)' is checked. This layer is not part of any group layer. The labels are not paused and they do not print. The lat/long for the feature is not 0,0 and the area is not NULL. There are no other features around it. When I click on 'View Unplaced Labels' from the Labeling toolbar nothing happens. I have also tried removing the shapefile from my map and adding it back again. I have tried adding the shapefile to a new map altogether. No luck on either. I have even tried creating a new shapefile and feature class inside of GDB, copy and pasting the feature and tracing the outline of the feature. Still no label.

The only way I have been able to see labels at all is when I zoom in closer than 1:150,000.

I have ended up just creating an annotation DB for the label, but still want to know why this might be happening. Is there a way to fix it? And/or is there a way to prevent this from happening in the future.

Update:

This is what I am trying to accomplish at a smaller, more zoomed out, scale.

enter image description here

Everything is showing up the way I desired and expected at this scale. However, when I zoom out beyond this, closer to the statewide scale, this happens.

enter image description here

You can see the label disappears and for some reason it is not reading as an unplaced label either.

1

Do you have a reference scale set in your dataframe? If not, and the label is too large for the polygon when you zoom out, that could cause it to be unplaced. It's odd that the label is still placed with SLE though.

Is Overrun enabled (Fitting Strategy tab)? Does the label show in red when you turn on unplaced labels? Do you have another version of ArcGIS you can try?

It may be that there is a problem with the geometry of your polygon which is causing Maplex to fail. In this case, you will have to raise a support call.

Update:

This is what I mean when the labels are too large for the polygon. The reference scale is not set, so when you zoom out to 1:8,000,000, the labels are overlapping the polygon boundary.

polygon labels

I've turned off overrun to make the labels unplaced, but you can get the same effect by adding another label class and setting the boundary weight to 1000.

enter image description here

Even though the 'barrier' label class is not enabled, the weights still have an effect on other label classes.

  • There is no reference scale in the Data Frame. I have enabled and disabled Overrun feature with tiny numbers and astronomical numbers and Asymmetric Overrun. If there was a problem with the polygon geometry why does it label in beyond 1:150,000? – mgregor Feb 25 '16 at 13:36
  • I updated my question. You will notice that my label is not coming in unplaced even though it is showing up at the larger more zoomed in scale. – mgregor Mar 1 '16 at 14:15
  • @mgregor do you have Remove duplicates enabled [desktop.arcgis.com/en/arcmap/latest/map/working-with-text/…? Labels will not show as unplaced if they have been removed. Also, I wouldn't recommend using weights of 1000. I was only doing that to show how a boundary weight can make the labels unplaced. – jon_two Mar 2 '16 at 15:47
  • I do not have Remove duplicates enabled. There is only one polygon so I didn't bother. I also just used 1000 to show that I adjusted the weights. You can see though that the labels aren't even showing up unplaced. – mgregor Mar 2 '16 at 17:36
  • @mgregor I think you'll have to raise a support call, so someone from Esri can look at all your mxd properties and data to see if there is a bug in there. – jon_two Mar 3 '16 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.