4

I have a vector symbol that I am using rule based style with. In the Rule properties tab I click on the SVG marker and change the "rotation" which is a field I have made to handle to the rotation angle I want per each row for this feature. Am I setting this up wrong?

enter image description here

enter image description here

Every record has a slightly different Rotation so when I look at the symbols they should all not be straight up and down.

6
  • 1
    Your settings seem ok, except maybe the "Output preview" (bottom left corner of your first image) which looks a bit weird. Are you sure your "rotation" field is correct?
    – ArMoraer
    Feb 25 '16 at 20:39
  • The attribute table has the rotation field in degrees. I guess I don't know how I would change it. This is the first time I have ever done anything in QGIS like this.
    – Kyle Kouri
    Feb 25 '16 at 21:01
  • 1
    As @ArMoraer mentioned, you have shown a correct way of setting your rotation. Can you give a sample of what values your "rotation" field holds?
    – Joseph
    Feb 26 '16 at 11:05
  • -0.086399280254598, -100.517556011665, 56.0090348246834
    – Kyle Kouri
    Feb 26 '16 at 15:27
  • These are three different values just to let you know. I could not figure out how to copy and paste a pic.
    – Kyle Kouri
    Feb 26 '16 at 15:28
-1

I have created a style that converts symbol angle given in radians*10000 and with 90 deg offset in "SUUNTA". The input field is integer64 having both positive and negative values. 90 - "SUUNTA" /10000/pi()*180

This worked fine with QGIS 3.x but now 3.12.3 using the same style gives random results. First the symbol was always at 90 degrees despite the values. By updating the values range resulted that the direction is there but now 90 degrees offset. After replacing the definition to: 180 - "SUUNTA" /10000/pi()*180 did not change anything, it is still the same 90 degrees offset from the correct value This is weird.

1
  • 1
    Is this an answer or a question? May 14 '21 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.