I'm running ArcGIS 10.3 with an Advanced License on a Windows 7 64x system with 20 GB of RAM and a 4th Gen Intel i7 Quadcore-CPU.

I have a problem with the normally very efficient Union tool. What I'd like to achieve is a simple union of two feature classes in order to fill holes in my main feature class, say "flat areas" (blue). I therefore created a large surrounding polygon "union polygon" (green). The below images explain the situation (overview and zoomed in):

overview detail

My blue feature class is large (60 MB), but not huge. It was created combining different features, then I ran the dissolve and buffer tools on it.

The problem now is that when I try to unify the two feature classes, ArcCatalog returns "Error 999999: Error executing Function. Invalid topology". I have read this answer about processing large data and followed as many of the instructions as possible:

  • No network drive
  • SSD
  • dissolved polgons

So finally my questions:

  • Does anyone have an idea what could cause the problem? Hardware issue?
  • Any further tipps or recommendations about the Union tool?
  • Or even better - an alternative in order to fill the holes in the "flat areas" feature class?


I've meanwhile found this post: Invalid Topology [Topoengine error] from ArcGIS for Desktop? which seems to be about the same problem as I'm experiencing, however there isn't a solution either. I'm currently running the Repair Geometry tool.

Also I've tried to run identity instead of union since that would also work for my task. The same error showed again.

  • 1
    Have you run check geometry tool to see if your data has invalid self intersecting data?
    – Hornbydd
    Feb 26, 2016 at 8:52
  • Thanks @Hornbydd for your remark. This lead me in the right direction.
    – dru87
    Feb 26, 2016 at 9:37

1 Answer 1


My question is probably a duplicate of the following two questions:

However, I will try to summarise the problem into one answer in order to have a complete overview of the problem and its solution:

Possible Cause:

  • When creating large polygon layers (through tools in the Analysis Toolbox) ArcGIS might create tiles due to a maximum number of nodes in polygons. These tiles are prone to topology errors.


  • Work on a local drive, if possible SSD
  • Try to use dissolved polygons
  • Simplify polygons if possible
  • Check whether you might be able to perform the tool in_memory (depends on your hardware and the size of your feature class)
  • Delete uncessesary fields in the feature classes


  1. Reboot machine, Restart ArcCatalog, don't use ArcMap for the task
  2. Use the Repair Geometry tool (data management toolbox), try again
  3. Copy your data to a new FGDB, try again
  4. Split your features to be processed into smaller parts, try again
  5. Upgrade hardware, try again

Not the answer you're looking for? Browse other questions tagged or ask your own question.