I am working on a Project for an assignment. Basically I want the points on the map to have a three mile radius around them. The places are from a shapefile. Once I try to set a radius I am selecting the Place pin and using Geo processing -> Buffer.

I set the buffer distance to 1 and I have also tried setting the buffer to different distances and still I end up with the same sized radius. Can anyone help?

enter image description here

  • 1
    What is the coordinate system of your shapefile? – Hasan Mustafa Feb 26 '16 at 11:32
  • I agree, it looks like you are working with a geographic crs, for buffer (or anything distance realted really) you need a projected crs. 1 is here the layer unit, if its wgs84 e.g. degree/square degree. You want miles. So Project (save) your layer and change the crs while doing so (e.g. epsg 3395). Then it should work, also set the project to the same crs (right lower corner). – Jason Feb 26 '16 at 12:11
  • The project is set to EPSG:27700 British National Grid. The Places Shape file is set to CRS EPSG:4326, WGS 84 However once i change this to the British National Grid it doesnt work. – Whitena Cording Feb 26 '16 at 12:11
  • 1
    Working with mixed SRID's in a project is asking for trouble, you should bring project your data and bring it in the same coordinate system (you ll need it to be projected since you want to use 3miles as a unit) take a look at the question @wittich linked, that should work – Hasan Mustafa Feb 26 '16 at 12:16
  • Changing the CRS of the shapefile with Set Layer CRS does not work. You have to Save As... the shapefile to another file and CRS. – AndreJ Feb 26 '16 at 12:25

Found a solution that worked a charm. I followed this method - Possible duplicate of Understanding QGIS buffer tool units? – wittich

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.