2

I'm trying to compile QGIS-master 2.12 for the first time following the INSTALL guide (https://github.com/qgis/QGIS/blob/master/INSTALL). I'm stucked while compiling with the "CMake Error at cmake/FindQCA.cmake:64".

Here is my environment:

  • Windows XP SP3
  • Qt 4.8.7
  • Qt Creator 3.6.0
  • Microsoft Visual Studio 10.0
  • Windows SDK for Windows 7 and .NET Framework 4
  • CMake 3.0.2
  • OpenSSL 1.0.2f
  • OSGeo4W (expat, fcgi, gdal, grass, gsl-devel, iconv, pyqt4, qt4-devel, qwt5-devel-qt4, sip, spatialite, libspatialindex-devel, python-qscintilla)
  • Cygwin (bison, flex, git)
  • I tried to install QCA from the source but I can't get it work.

Any advice on how to go ahead?

Here is the log when I try to compile QGIS in QtCreator:

-- The C compiler identification is MSVC 16.0.30319.1

-- The CXX compiler identification is MSVC 16.0.30319.1

-- Check for working C compiler: C:/Program Files/Microsoft Visual Studio 10.0/VC/bin/cl.exe

-- Check for working C compiler: C:/Program Files/Microsoft Visual Studio 10.0/VC/bin/cl.exe -- works

-- Detecting C compiler ABI info

-- Detecting C compiler ABI info - done

-- Check for working CXX compiler: C:/Program Files/Microsoft Visual Studio 10.0/VC/bin/cl.exe

-- Check for working CXX compiler: C:/Program Files/Microsoft Visual Studio 10.0/VC/bin/cl.exe -- works

-- Detecting CXX compiler ABI info

-- Detecting CXX compiler ABI info - done

-- QGIS version: 2.13.0 Master (21300)

-- Could not find GRASS 6

-- Could not find GRASS 7

-- Found Proj: C:/OSGeo4W/lib/proj.lib

-- Found GEOS: C:/OSGeo4W/lib/geos_c.lib (3.5.0)

-- Found GDAL: C:/OSGeo4W/lib/gdal_i.lib (2.0.2)

-- Found Expat: C:/OSGeo4W/lib/libexpat.lib

-- Found Spatialindex: C:/OSGeo4W/lib/spatialindex_i.lib

-- Found Qwt: C:/OSGeo4W/lib/qwt5.lib (5.2.1)

-- Found Sqlite3: C:/OSGeo4W/lib/sqlite3_i.lib

-- Found PostgreSQL: C:/OSGeo4W/lib/libpq.lib

-- Found SpatiaLite: C:/OSGeo4W/lib/spatialite_i.lib

-- Could NOT find ZLIB (missing:  ZLIB_LIBRARY ZLIB_INCLUDE_DIR)

-- Could NOT find PNG (missing:  PNG_LIBRARY PNG_PNG_INCLUDE_DIR) 

-- Could NOT find JPEG (missing:  JPEG_LIBRARY) 

-- Could NOT find TIFF (missing:  TIFF_LIBRARY) (found version "4.0.2")

-- Could NOT find ZLIB (missing:  ZLIB_LIBRARY ZLIB_INCLUDE_DIR) 

-- Found Qt version: 4.8.6

-- Touch support disabled

-- Found QScintilla2: C:/OSGeo4W/lib/qscintilla2.lib (2.8.4) 

CMake Error at cmake/FindQCA.cmake:64 (message):   Could not find QCA Call Stack (most recent call first):   CMakeLists.txt:312 (FIND_PACKAGE)

-- Configuring incomplete, errors occurred! See also "//mac/Home/Desktop/build-QGIS-master-Desktop-Default/CMakeFiles/CMakeOutput.log". See also "//mac/Home/Desktop/build-QGIS-master-Desktop-Default/CMakeFiles/CMakeError.log".
  • 1
    Did you install the qca development package from osgeo4w? – Matthias Kuhn Feb 26 '16 at 13:45
  • @MatthiasKuhn could you add that as an answer so the question can be marked as answered? – underdark Feb 28 '16 at 19:50
1

You need to install the qca development package. On windows this can be done from the osgeo4w setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.