2

I am trying to label a line which contains 431 segments. I need to label each segment with a simple GIS_ID number. When I label the segments, many go unlabeled. Is there any way I can label all 431 segments?

  • 2
    Are you sure that they aren't being labeled at all? If they are short segments and you are zoomed out, it is possible the GIS software you are using isn't displaying all of them because they would be overlapping. Otherwise, can you maybe add a picture of what's happening, extra detail about the software you're using (QGIS, Arc, etc) and some info about the layer you are trying to label? – wmebane Feb 26 '16 at 20:17
  • By labeling segments do you mean you want to see a label between every pair of vertices? – PolyGeo Feb 26 '16 at 20:26
2

Try using ArcGIS Maplex Engine or the 'Label' toolbar in ArcMap.

From here, you can turn on 'View Unplaced Labels' and see whether or not they are being calculated. Likely, as @wmebane commented above, they are there, you're just zoomed out at an extent that makes it impossible to view. If you are working on creating these for a printable map, make sure you switch to 'Layout View' and have the page settings correct. Here, you will see red splotches where the labels are not being created, or black where they are.

It's also possible that you have labels stacked upon each other and may need to offset them. These settings can all be handled in the Label Manager.

enter image description here

0

To check which label engine you are using, in ArcMap right-click on 'Layers' in your Table of contents > Properties and select your label engine in the drop down (if available).

enter image description here

If you have Maplex in your properties of the layer you're trying to label you can force it to label every segment by going to the layer you want to label and

  • open the layer properties > 'Placement Properties' > under the 'Conflict Resolution' tab select "'Never Remove' (place overlapping)"

  • For the standard label engine you may need to play around with the settings. Again open the layer properties for the layer you wish to label and try I would select under 'Placement Properties' select "Place one laber per feature part".

    Under 'Conflict Detection' update Feature Weight to 'High'. And check on 'Place overlapping labels' at the bottom

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.