3

I've been unsuccessfully trying to install QGIS using Homebrew (used Homebrew to install GDAL and GSL) as outlined here

My OS is Mac Yosemite, 10.10.5. The installation sort of finishes, but with a warning

Warning: The post-install step did not complete successfully You can try again using brew post install osgeo/osgeo4mac/qgis-26

The app does not start due to lack of compatibility with MacOX system.

I also tried to use the .dmg from http://www.kyngchaos.com, but it does not even open the image complaining that GDAL 1.11 is not installed, when in fact it is.

Any tips, please?

UPDATE

I tried with qgis28 and still get the following warning during installation:

==> Pouring qgis-28-2.8.3.yosemite.bottle.tar.gz

==> defaults delete "/usr/local/Cellar/qgis-28/2.8.3/QGIS.app/Contents/Info.plist" LSEnvironment

==> defaults write "/usr/local/Cellar/qgis-28/2.8.3/QGIS.app/Contents/Info.plist" LSEnvironment "{ 'PATH' = 'home/.rbenv/s
Last 15 lines from home/Library/Logs/Homebrew/qgis-28/02.osgPlugins-3.4.0';:

Warning: The post-install step did not complete successfully
You can try again using `brew postinstall osgeo/osgeo4mac/qgis-28`
*(which upon running returns the very same warning)*

defaults write "/usr/local/Cellar/qgis-28/2.8.3/QGIS.app/Contents/Info.plist" 
LSEnvironment "{ 'PATH' = '(my paths) 'PYTHONPATH' = '/usr/local/Cellar/qgis-28/2.8.3/lib/python2.7/site-packages:/usr/local/lib/python2.7/site-packages'; 'GDAL_DRIVER_PATH' = '/usr/local/lib/gdalplugins'; 'GRASS_PREFIX' = '/usr/local/opt/grass-64/grass-6.4.4'; 'OSG_LIBRARY_PATH' = '/usr/local/lib/osgPlugins-3.4.0'; }"

Could not parse: { 'PATH' = '(my paths)' } Try single-quoting it.

upon starting qgis

Warning: loading of qgis translation failed [/usr/local/Cellar/qgis-28/2.8.3/QGIS.app/Contents/MacOS/../Resources/i18n//qgis_en_US]

Warning: loading of qt translation failed [/usr/local/Cellar/qt/4.8.7_2/translations/qt_en_US]

Warning: QGraphicsScene::addItem: item has already been added to this scene
ERROR 1: dlopen(/usr/local/lib/gdalplugins/gdal_GRASS.so, 1): Library not loaded: /usr/local/lib/libgeos-3.4.2.dylib
  Referenced from: /usr/local/opt/grass-64/grass-6.4.4/lib/libgrass_vect.6.4.4.dylib
  Reason: image not found

ERROR 1: dlopen(/usr/local/lib/gdalplugins/ogr_GRASS.so, 1): Library not loaded: /usr/local/lib/libgeos-3.4.2.dylib
  Referenced from: /usr/local/opt/grass-64/grass-6.4.4/lib/libgrass_vect.6.4.4.dylib
  Reason: image not found
  • I have libgeos-3.5.0.dylib, not libgeos-3.4.2.dylib. Where could I change version referencing?
  • I have Python2.7 as the system default version and miniconda's Python3.

I did notice confusions between Python versions and GDAL. Unfortunately, have not been able to figure it out yet. When I do brew link gdal, it links to Python2.7 and can't use it with IPython3 (obviously...), but when I unlink it, the command line tools (ogr2ogr) does not work.

What am I missing and how to fix the geo-toolkit (GDAL+QGIS working together in peace)?

  • Any warning pop-up related to dependencies during the install at any point? – whyzar Feb 26 '16 at 23:04
  • @whyzar I've included the output above – Anna Magdalena Feb 27 '16 at 20:26
2

Mac OS X is an Unix system where the paths and the links are very important and you are mixing two things (look at QGIS on Mavericks, Error Updating Gdal with Homebrew or QGIS python location problem, for example).

In short, the installation paths and the links are different:

  1. Homebrew uses libraries and executables installed in /usr/local/Cellar with symbolic links in /usr/local/bin
  2. The Kyng Chaos QGIS version uses Frameworks installed in /Library/Frameworks/GDAL.framework (for example). It is stipulated in the download page

Requirements: GDAL Complete 1.11 framework package, Matplotlib Python module

Therefore, the compiled QGIS versions of Homebrew and Kyng Chaos use different links and you cannot use the GDAL library installed in /usr/local/Cellar with the Kyng Chaos version and vice-versa unless you are a Unix specialist or compile yourself QGIS

These Unix paths allows to use at the same time the Homebrew and Kyng Chaos versions without interferences.

  • Thanks @gene. So I focused on 1), thus the QGIS via Homebrew installation attempt. I installes GDAL, GSL, QGIS via Homebrew, and still having version/link problem. Any hints? – Anna Magdalena Feb 27 '16 at 21:52
  • Use the Kyng Chaos version, it's the easiest to install. There are many versions of Homebrew QGIS ( Homebrew/-science:QGIS, homebrew-osgeo4mac, etc.) with problems – gene Feb 27 '16 at 22:39
  • Then I also need Kyng Chaos versions of GDAL etc, right? And there will be no conflicts with the Homebrew ones? (e.g. using Python gdal pip installed package) – Anna Magdalena Feb 27 '16 at 22:53
  • The Kyng Chaos version uses the Apple Python (in /usr/bin) and the Homebrew version uses the Homebrew Python (in /usr/local/bin) – gene Feb 28 '16 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.