1

I have georeferenced an old jpg map against Bing Road maps (OpenLayers plugin) and Raster>Georeferencer. I'm trying to use EPSG:4326 because my PostGIS database uses that. My PostGIS info shows coordinates in decimal degrees where they should be. But my georeference jpg show coordinates as -13000000 (not all zeros, but 13 million something), 4000000 (4 million something). Seeing EPSG:4326 as the CRS. What are these large coordinates and what do they mean?

Main problem is that the georeferenced jpg isn't where it's supposed to be. I have no idea where it is. I'm using zoom to layer to see it.

Side question. Is is possible to zoom to two layers at once? Would help with problems like this.

I'm using latest QGIS on a Mac.

2

If you georeference against the Openlayers Bing layer by clicking on the canvas, you have to use EPSG:3857 as project CRS and target CRS for the Georeferencing.

Once done, you can reproject the raster into any CRS you want with Raster -> Projections -> Warp using a different filename.

  • Thank you. That makes some sense. I've been experimenting some and realized Bing and 3857 were locked together somehow. I'm also having trouble getting with the final referencing in that some of the trials are all black or distorted. I'll do more reading on conversion settings. – Greg Feb 28 '16 at 6:34
  • 1
    It's not bing, but the Openlayers plugin that requires EPSG:3857. You can try the new QuickMapServices plugin which can handle CRS reprojections better. – AndreJ Feb 28 '16 at 6:46
  • Thank you, that helps. Georeferences plugin allows selecting a CRS, but are you saying using Openlayers plugin with Bing means that the Georeferences setting are ignored? Is it important that I select a CRS for the georeferenced map. My data is in EPSG:4326, but if QGIS can handle layers of various projection without trouble I'm thinking I should not fight plugins like Openlayers (which as far as I see in the About me and setting doesn't specify EPSG:3857) – Greg Feb 28 '16 at 16:57
  • If you georeference against a background in EPSG:3857, you have to set the Georeferencing result to that CRS too. Handling of different CRS does not work here. – AndreJ Feb 29 '16 at 6:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.