0

I am fairly new to QGIS, but I had successfully installed QGIS 2.12 on Windows 10 with several plugins, and it worked OK. I wanted to try the Boundless OpenGeo Explorer plugin for QGIS but there was an error on installation. I had had a previous error trying to update the Processing plugin, so I decided to uninstall QGIS, and reinstall a clean version (2.8) from Boundless, as this would have the OpenGeo Explorer plugin pre-installed.

The installation seemed to go OK, but now QGIS will not start properly. It reports something like

Couldn't load plugin XXX due to an error when calling its classfactory() method

for several plugins (MetaSearch Catalogue Client, qgis2web etc). Then I get

Couldn't load plugin 'opengeo' from ...",

and the same for plugin processing.

On startups I do get to the QGIS screen, and from the plugins option I notice that there are two entries for the Boundless plugin repository. I cannot delete either of them. And it seems to have carried over the non-core plugins I installed before into what was supposed to be a clean installation. Several of the plugins are said to be invalid.

1

The most important folder for the plugins is the .qgis2 folder, installed in your Home folder with the plugins in .../.qgis2/python/plugins

enter image description here

This folder (../.qgis2) is valid for all QGIS 2.x versions and it is not deleted when you uninstall a version of QGIS.

When you install a new version of QGIS, it uses the existing .qgis2 folder if the installer found one or it install a new qgis2 folder.

Therefore, you try to install the Boundless version (2.8) with plugins already installed for the version 2.12 -> many errors because you downgrade QGIS (2.12 -> 2.8)

Furthermore, if you work with standalone versions in Windows, each version of QGIS has its own Python interpreter. If you know Python, you also know that the python scripts (.py) are "compiled" into .pyc files (compiled bytecode of Python source files) and the Python interpreter loads .pyc files before .py files.

So you might experience two problems:

  1. the installed plugins (for QGIS 2.12) are not compatible with the QGIS 2.8 version -> processing for example.
  2. the old .pyc files (QGIS 2.12) are not compatible with the new Python version (Boundless QGIS)

The best solution is then to delete the .qgis folder, then install a new version of QGIS and reinstall your plugins.

(If you want to delete a plugin, simply trash it (from the folder ../.qgis2/python/plugins)

Hope that will be useful!

0

I have solved the plugins errors, by uninstalling a 64 bit version of Python I had installed a few weeks ago. I do not know Python, but it was just something suggested to me in a different context. Presumably I should have chosen the 32 bit version at that time?

It is still odd to me that the new install does pick up the previous plugins I had installed, but it is not an issue as would have wanted to re-install most of them anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.