2

I am building a rather large model. And I am trying to keep the files original name in the output file. Example being. Original File is called: Line.shp. I want to dissolve Line.shp so in model builder I write the output dissolved files name as %Name%_dissolve.

However, I keep getting this error: ERROR 000354: The name contains invalid characters

3
  • Are you actually creating shapefiles as suggested by your question or geodatabase featureclasses? "Line.shp" would be an invalid featureClass name as you have a dot in it.
    – Hornbydd
    Feb 29, 2016 at 21:31
  • Creating a shapefile. Also the "Line" name is just an example, and the .shp is simply the extension.
    – V0921psc
    Mar 1, 2016 at 22:48
  • OK so what is not an example what are you using?
    – Hornbydd
    Mar 1, 2016 at 23:17

1 Answer 1

4

On the ModelBuilder menu tab, in the Insert group.

Select Tools (these are "Model Only Tools"), select "Parse Path".

After tool appears, click the link button on the toolbar.

Make a link between your Line shapefile and the Parse Path tool.

Double click to bring up tool properties.

From the Parse Type parameter, select File Name.

Click OK.

The output of the tool should be "Value".

For the output file name use "%Value%_dissolve".

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.