7

I cannot figure it out to move Labels in an QGis-Layer. I added two columns (x,y) and set these columns as Data-defined-Position in the layer-properties as descriped in some (older) threads (e.g. How does manual Label Placement in QGIS 1.9 work? or Is there a way to manually place labels in QGIS?).

The button to move the label is greyed out. I am using a shp-layer with polygones in QGis 2.14.

Is there a way to to this (without using a plugin)?

edit: Here some screenshots of the problem: enter image description here enter image description here enter image description here

  • Which button is "greyed out"? (Properties-->Labels-->Placement-->Offset-->Data defined? That one? – Jason Mar 2 '16 at 10:33
  • did you turn on editing for the layer? – Ian Turton Mar 2 '16 at 10:56
  • Editing is turned on for the layer and the buttons for rotating, moving and "Show/hide label" in the labeling toolbox are greyed out. The other button of the toolbox are eneabled.The button "Change Label" is eneabled. Selecting this button and klicking on a Label, the window "Label properties" will open, but only the field "Text" is eneabled. – vezzon Mar 2 '16 at 11:25
  • I just tried it and it worked for me.... everything you klicked plus take the option: field type... and then pick the right column. I can post screenshots too if you want.. Also i was not in the edit mode... If that is not it I don't can't reproduce the problem... but the "y" is your current selection... coordinate system trouble maybe? – Jason Mar 2 '16 at 12:07
  • 1
    Did you save the newly added x and y column before using the data binding x and y label coordinates? Otherwise I cannot reproduce your issue. – Jakob Mar 2 '16 at 12:21
7

From your screenshot I suspect that you are setting the data defined x and y to the expressions "x" and "y", rather then directly binding them to the field itself.

Make sure you use the "attribute field" submenu in the data defined popup menu and select your x and y fields from that menu, rather then using expressions.

  • I got it! You are right. The mistake was, to use the name of the added column (e.g. "x") in the settings of the data defined section. You have to use the "attribute field" submenu in the data defined popup menu and select the x and y fields from that menu!!! Thank you! – vezzon Mar 3 '16 at 8:43
3

An appreciation for the answer: if the labels have rules, the button to move the label remain greyed out. Better labels without rules.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.