2

I've been dealing with various problems after re-installing QGIS and other GIS-related software (see QGIS corrupted plugins upon reinstallation).

The solution worked for a bout a day and now I lost the processing tool again. An other error message appeared when opening QGIS:

Impossible to load processing plugin provokes error when calling classFactory()

UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 18: ordinal not in range(128)

Traceback (most recent call last):
  File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 306, in startPlugin
    plugins[packageName] = package.classFactory(iface)
  File "C:/Users/F�lix/.qgis2/python/plugins\processing\__init__.py", line 37, in classFactory
    from processing.ProcessingPlugin import ProcessingPlugin
  File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/Users/F�lix/.qgis2/python/plugins\processing\ProcessingPlugin.py", line 47, in 
    if cmd_folder not in sys.path:
  File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 58, in showWarning
    "warning:%s\ntraceback:%s" % (warnings.formatwarning(message, category, filename, lineno), stk),
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 18: ordinal not in range(128)

Also, I have a second error when trying to re-install the processing extension through QGIS.

ImportError: cannot import name defaultOutputFolder

Traceback (most recent call last):
  File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 281, in loadPlugin
    __import__(packageName)
  File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/Users/F�lix/.qgis2/python/plugins\processing\__init__.py", line 28, in 
    from processing.tools.dataobjects import *
  File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/OSGEO4~1/apps/qgis/./python/plugins\processing\tools\dataobjects.py", line 35, in 
    from processing.core.ProcessingConfig import ProcessingConfig
  File "C:/OSGEO4~1/apps/qgis/./python\qgis\utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "C:/Users/F�lix/.qgis2/python/plugins\processing\core\ProcessingConfig.py", line 32, in 
    from processing.tools.system import defaultOutputFolder
ImportError: cannot import name defaultOutputFolder

Any ideas on how to solve this one?

  • 1
    @Joseph Nice catch! Another reason for QGIS to make the switch to Python 3 rather sooner than later. – Kersten Mar 2 '16 at 15:59
  • 1
    @Joseph wow that did the trick actually! I now remember various problems occuring last fall during my Python class, because of the user name. I just created a new one and voilà!! Thanks a lot! – Ninja Tuna Mar 2 '16 at 17:16
  • @NinjaTuna - Awesome, glad it worked! Will post the comment as an answer for the convenience of others =) – Joseph Mar 3 '16 at 10:34
3

One of the main culprits which forces a Unicode error is the user name. In this case:

"C:/Users/F�lix/...

Probably the best solution in these circumstances is to create a new user with a name which doesn't use characters with accents or similar symbols (i.e. Non-ASCII characters).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.