1

I am trying the QGIS OpenGeo Explorer plugin tutorial at http://suite.opengeo.org/opengeo-docs/qgis/explorer/tutorial/.

When I try "Publishing a QGIS project", with the quickstart project supplied for the tutorial, I get the error message:

'QgsRasterLayer' object has no attribute 'geometryType' (details below)

If I try publishing my own QGIS project I get exactly the same error, so it seems not be a problem with the project itself.

I do wonder if it is a version issue, as when I earlier created a new catalog I got a message something like

the specified catalog seems to be running an older or unidentified version of Geoserver

But having searched for the issue, it seems that it can be a spurious message so I felt fairly safe continuing. It is a recent installation: QGIS 2.8.3-Wien, and OpenGeoSuite 4.8, on Windows 10.

Any ideas?


Details of the error:

Traceback (most recent call last):

  File "C:/PROGRA~2/BOUNDL~1/QGIS/qgis/apps/qgis/./python/plugins\opengeo\gui\explorer.py", line 111, in run
    command(*params)
  File "C:/PROGRA~2/BOUNDL~1/QGIS/qgis/apps/qgis/./python/plugins\opengeo\qgis\catalog.py", line 475, in publishLayer
    sld = self.publishStyle(layer, overwrite, name)
  File "C:/PROGRA~2/BOUNDL~1/QGIS/qgis/apps/qgis/./python/plugins\opengeo\qgis\catalog.py", line 148, in publishStyle
    sld, icons = getGsCompatibleSld(layer)
  File "C:/PROGRA~2/BOUNDL~1/QGIS/qgis/apps/qgis/./python/plugins\opengeo\qgis\sldadapter.py", line 199, in getGsCompatibleSld
    return adaptQgsToGs(sld, layer)
  File "C:/PROGRA~2/BOUNDL~1/QGIS/qgis/apps/qgis/./python/plugins\opengeo\qgis\sldadapter.py", line 61, in adaptQgsToGs
    if layer.geometryType() == QGis.Point:
AttributeError: 'QgsRasterLayer' object has no attribute 'geometryType'
  • I have done a fresh install (including deleting qgis2) and tried again. The error is exactly the same. – Peter Cooper Mar 3 '16 at 9:44
  • Please use Geoserver Explorer plugin instead of the old OpenGeo plugin. – Luigi Pirelli Mar 8 '16 at 8:32
  • I have tried the Geoserver Explorer plugin in both QGIS 2,8 and 2.14. I do not get the error reported above. I do not yet know GeoServer well enough but both my test map and quickstart examples seem to load OK. – Peter Cooper Mar 8 '16 at 9:57
  • The only issues I found on a cursory look were (1) the option to overwrite without asking worked OK on quickstart but not my own map; (2) my map had an error message 'NoneType' object has no attribute 'type' (but still loaded OK) >Traceback (most recent call last): > File "C:/...\geoserverexplorer\gui\explorer.py", line 98, in run >command(*params) – Peter Cooper Mar 8 '16 at 10:11
  • Hi Peter, please file tiket here: github.com/boundlessgeo/qgis-geoserver-plugin/issues (if not already present)... with detail to reproduce the issue. – Luigi Pirelli Mar 9 '16 at 10:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.