4

I am using QGIS 2.12.3

I have two layers, one a complete grid of 1km squares, the other polygons representing urban land.

Whether I intersect clip or difference these two layers, some of the km squares are omitted from the new layer. It can't be a data issue as the missing squares are different depending on which operation I undertake, although they appear consistent for each operation.

Can anyone explain - I must admit I find the geoprocessing tools can often ignore a polygon on an layer with no obvious reason (yes I have tried validating the layers with no errors).

I have managed to upload an image - the ignored squares are the white one 'peeping' from behind the urban layer

Note how the same polygon interacts properly with many other squares.

The polygon does fail validation but I have been around the periphery of failed squares and can see no faults.

  • 2
    can you add a screenshot of the resulting layers with the missing squares? – HDunn Mar 3 '16 at 13:01
  • 2
    if you have Shapefiles you can update the spatial index. – klewis Mar 3 '16 at 14:21
  • Could you upload your shapefiles to a public server so that others could test it? – Joseph Mar 4 '16 at 10:45
  • Had this same problem and I think converting to single-parts and updating my spatial index did the job. – Sethinacan Mar 4 '16 at 11:42
  • I prepared a svreenshot - but I can't see how to add it. – Stub Mandrel Mar 4 '16 at 14:41
2

I have encountered a similar situation when using QGIS for clipping a polyline layer using a polygon layer.

The problem is the following (as I have understood it): the layer to be clipped has to be singleparts (a attribute table record for each feature) layer. When clipping, the result layer might contain multiple features for one record and I believe that this is causing exclusion of other features. QGIS has 2 functions named "Multipart to singleparts" and "Singleparts to Multipart" under Vector->Geometry Tools section that might be helpful for you.

I hope this helps a bit to find a workaround for this issue.

Regards, Ioana

  • Thanks, I'm afraid that hasn't worked. I have even created a new grid from scratch, and still the same squares are omitted. Interestingly, looking closely at one square that doesn't work it is only overlapped by one polygon - at several points, but other squares intersected by it in the same fashion work perfectly. – Stub Mandrel Mar 3 '16 at 14:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.