In QGIS 2.12 and down, when one went about manually setting the GRASS provider folder paths, this was the way to do it enter image description here

In GIS 2.14 there is no Msys folder in the same path (...\apps\msys) or any other folder in the QGIS installation. enter image description here

So even though QGIS standalone needs to have it set correctly in order for GRASS tools to work, it can't be done. enter image description here enter image description here

So how do you make GRASS tools work in QGIS 2.14?


3 Answers 3


I got the same problem using the Osgeo installer, but I just managed to solve it.

First download this https://sourceforge.net/projects/mingw/?source=typ_redirect

Install it, look for msys-base package and install it.

Set the path to msys in QGIS to "C:\MinGW\msys" or what ever local drive it was installed on and the Grass algorithms should work fine.

  • Thanks, this worked. Though after I installed it I realized it doesn't matter where the msys folder comes from and how it is installed, and that I already have in my 2.12 installation
    – HDunn
    Mar 13, 2016 at 14:14
  • I installed msys but and set the path, but Grass geoalgorithms did not work, used nightly 2.15 did not work either
    – user16032
    Mar 25, 2016 at 15:04

So here's the deal: QGIS 2.14 standalone doesn't come with msys installation, but comes with grass 7 folders. QGIS 2.12 standalone comes with msys and grass 6.4 folders, yet no grass 7.

The solution is as simple as copying the folders from one registry to the other.

I worked with both 2.12 and 2.14 to verify that this works, and it does.

In order to have all the grass functionality working in 2.14, I copied the msys (and grass 6.4) from QGIS 2.12 apps folder to the C:\Program Files\QGIS Essen\apps folder, and set the correct path in the providers setting.


I'm on OSX 10.11.3 and I've got the same bug with my 2.12 version downloaded from Kynchaos. I just download this file, unpack it in the msys folder that I created in the path indicated in processing options box. It seems working fine. I've got 160 Algorithms, I don't remember if it is the expected number, can someone confirm me ?

  • Similarly, I'm on OSX10.10.5 with QGIS 2.18.7 with same problem. I tried this suggestion: Within the Grass7 directory, I added msys directory. I then placed the unpacked msysCORE files in this directory. I exited QGIS and reentered and it still doesn't work. Anyone know what I'm missing?
    – Tom
    Jun 29, 2017 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.