1

I am trying to publish this map to ArcGIS Online:

Layer in ArcGIS Pro 1.2

These polygons are symbolized by color based on a categorical variable and extruded based on a numerical variable.

When I publish this layer it is treated as 2D:

WebScene on AGOL

I have adjusted elevation of the layer to "relative to the ground" and 43,000 m.

Any ideas why these polygons are not extruding properly in the web scene?

  • It could be many things like is your Z field a string type perhaps? Can we see your attribute data for the shapefile. Without more information it may be difficult to pinpoint your problem. – ed.hank Mar 3 '16 at 20:58
  • Are all the contents of the scene, such as elevation sources of the ground, basemap layer, and other layers, are in the same projected coordinate system? – whyzar Mar 3 '16 at 21:01
  • Can you show a screen shot of your contents pane, where the 2D and 3D layers would normally show up in ArcGIS Pro? – whyzar Mar 3 '16 at 21:14
1

Extruded polygons are not supported in Web Scenes at the current release.

Here's the documentation: http://pro.arcgis.com/en/pro-app/help/mapping/map-authoring/author-a-web-scene.htm (in particular, reference the table titled "polygons").

You can work around this limitation by using the "Layer 3d to Feature Class" GP tool to create a multipatch of the extruded polygons, then publishing that multipatch to a local or hybrid Portal - however you won't be able to publish it direct to ArcGIS Online as of this release.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.