3

I've spent a couple of days now troubleshooting a QGIS Server setup in Ubuntu 14.04.

I am following this guide to install QGIS server:
http://anitagraser.com/2012/03/30/qgis-server-on-ubuntu-step-by-step/

According to the guide above, the installation should respond to the request below.
wget -p -O - "http://localhost/cgi-bin/qgis_mapserv.fcgi?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities"

All I am getting is a 404. Apache 2 and FCGID are installed and enabled. I seem to be missing something.

I've tried the setup with 2.8LTR and 2.14LTR both unsuccessfully, but unable to solve this issue.

1

solved the issue by adding the following lines to the 000-default.conf in /etc/apache2/sites-available

ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/ <Directory "/usr/lib/cgi-bin/"> Options ExecCGI FollowSymLinks Require all granted AddHandler fcgid-script .fcgi </Directory>

I got the solution from this thread
Qgis server on Ubuntu Server 14.04: Permission denied

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.