1

I have used intersect (Analysis Tool) to intersect two polygon layers. But I got error 000117 after ran intersect tool. Same error message happened when I use clip (Analysis Tool). The answer and two shapefiles property shown as below.

So I was wondering how to amend this?

Error message 000117shapefile property


@GetSpatial The first layer is the high-density area shapefile of Washington-Arlington-Alexandria MSA polygon shapefile. And the second layer is multiple ring buffer of MSA Virginia part roads. I want to calculate the high-density area within each buffer. So I used intersect tool. The red area is the high-density area and yellow area is road buffer.

I tried to use other spatial operations and there was no problems happened before.

enter image description here

  • 1
    Have you used a Select by Location to be sure that the two polygons actually overlap in space? – Andy Bradford Mar 8 '16 at 21:22
  • As @AndyBradford mentioned, it sounds like you may have no overlap. It might help to post a screenshot of the two layers, as well as a bit of descriptive information about what they represent. As well, are you able to run other spatial operations on them without returning an error? Issues with other functions may indicate a geometry problem with one or both of the layers. – Get Spatial Mar 8 '16 at 21:35
  • It may also be an issue with geographic coordinate vs projected coordinate systems. Have you tried projecting each of these layers to some coordinate system, then trying this? – Get Spatial Mar 8 '16 at 21:38
  • @AndyBradford After your recommendation, I use select by location and it works. – Yabai Mar 8 '16 at 21:50
  • @GetSpatial I have tried to change this two layers' coordinate system and do the clip and intersect again. Still got error 000117 message. – Yabai Mar 8 '16 at 22:32
2

I just ran into this issue with one of my datasets that I was intersecting with a small mask file.The reason that it was returning a blank output was that this particular dataset was so big (approximately 2.5 GB, it's the human footprint dataset of Alberta, Canada, and can be accessed here) that the intersect tool couldn't process it. Instead of returning an error, it simply returned a blank file. There are several ways to solve this using python. The more complicated solutions are:

1) Split the files into tiles using the ArcGIS Dice tool or something similar, intersect each tile, and then use Merge to bring together the results.

2) Create a feature layer, and then use select by location to select only the polygons that overlap. Then use that selection to create a new feature class, and run the intersect on the new (smaller) feature class (this takes at least four lines of code, and depending on how much RAM you have, may be impossible).

The solution that worked for me was to simply set the processing extent. In my case, I am intersecting small masks with a much bigger file. I dynamically set the processing extent for each small mask as they were processed:

import arcpy

def SetExtent(shapefile):
    arcpy.env.extent = shapefile
    arcpy.env.mask = shapefile

footprint = arcpy.env.workspace + r"\human_footprint_dataset"
mask1 = arcpy.env.workspace + r"\mask1"
mask2 = arcpy.env.workspace + r"\mask2"
masks = [mask1, mask2]

for mask in masks:
    SetExtent(mask)
    arcpy.PairwiseIntersect_analysis([mask,footprint],r"\result_{}".format(mask))

For each smaller file, the processing extent was shrunk, allowing arcpy to only consider a small part of the much larger (2.5 GB) file.

So, in summary, the problem is that the file is just too big. The solution is to either break it up into smaller pieces, or shrink the processing extent. Hope this helps!

  • I don't see PairwiseIntersect in ArcGIS 10.4. It seems to bo included in ArcGIS Pro. – klewis Aug 9 '16 at 21:45
  • That's right, I was using Pro when I wrote the above, but the answer works just as well for the normal intersect tool. From my experience, the only salient difference is that Pairwise Intersect can take advantage of parallel processing - a huge advantage when dealing with large data sets. – Chris Aug 12 '16 at 1:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.