3

My previously working installation of QGIS 2.14 on Ubuntu 14.04 suddenly failed to start QGIS. I have been trying to reinstall QGIS without success. I have tried several ways to completely uninstall first, including this -

sudo apt-get autoremove
sudo apt-get autoclean 
sudo apt-get -f install
sudo apt-get autoremove qgis
sudo apt-get --purge remove qgis

Then, on trying to reinstall QGIS, install fails with this error -

Setting up qgis-providers (1:2.14.0+20trusty-ubuntugis) ...
/usr/lib/qgis/crssync: symbol lookup error: /usr/lib/libqgis_core.so.2.14.0: undefined symbol: initGEOS_rdpkg: error processing package qgis-providers (--configure): subprocess installed post-installation script returned error exit status 127

So qgis-providers is not getting configured. I have no idea what the undefined symbol issue might be.

I was using the qgis debian repository (http://qgis.org/debian) + the Ubuntugis repository (ppa.launchpad.net/ubuntugis/ubuntugis-unstable/ubuntu). Also tried qgis ubuntu repos (http://qgis.org/ubuntugis). Tried only debian qgis repos (with ubuntugis turned off. All combinations fail configuring qgis-providers with same error.

I was able to install qgis 2.0 from the standard Ubuntu repository apparently without problem, but I find that my QGIS project files saved from 2.14 will not open in 2.0.

This has me stumped. I thought for sure I could just reinstall to recover, but after several frustrating hours, I could sure use some help or clues to some resolution.

  • 1
    Have you tried the methods suggested here: gis.stackexchange.com/questions/133033/… – IanS Mar 9 '16 at 4:09
  • @IanS - Yes, have tried all of that. All combinations of qgis.org and ubuntugis sources resulted in the same install error. Thx. – ZanStrausz Mar 9 '16 at 21:03
  • 2.14 is no longer supported at all using qgis.org/debian. There is no version available. This bug should be closed because it can never be reproduced. If you get this bug with 2.18 you should consider reopening. Too see what the official qgis debian repo offers look here: qgis.org/debian/pool/main/q/qgis – Evan Carroll Nov 13 '16 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.