1

For ArcGIS 10.3.1 with new 10.3.1 file geodatabase raster mosaics we randomly produce an 80042019 error when building overviews (which fail to build). In some circumstances the participating rasters in the mosaics are removed after the build overview fails. We approached Esri Inc technical support in USA but they were unable to replicate the issues.

Trolling technical forums has furnished me with a very small check list. All of which we have accounted for in testing, including:

  • Path file names length do not exceed 256 characters
  • File names do not break windows naming conventions
  • Raster's are visible in the mosaic and exist (double checked via repair)
  • There's no permission issues

enter image description here

The issue has been observed on a raster mosaics with only two rasters (one built, the other did not), and on raster mosaics with many rasters (15 odd raster's 36 did not build).

The rasters are added to mosaics on an ad hoc basis by different users. I suspect this the underlying reason, and it's probably to do with the mosaics properties conflicting with loaded rasters. My next tests will concentrate on rebuilding raster statistics and then mosaic histogram before the build overviews. But I'm flying blind. Has anyone see this issue before?

1

I replicated the 80042019 error after I made a local copy (rasters and mosaic) and repaired the mosaic raster paths. I concluded it was not a network issue. I then ran the Analyse Mosaic tool and determined that there were no statistics or histogram. I ran the build statistics and pyramids geoprocessing tool on the mosaic and then build overviews, opting to rebuild all overviews. The build overviews worked without error and the overviews were generated.

Conclusion: The 80042019 error can be caused by rasters and the mosaic not having statistics, pyramids, or a histogram.

| improve this answer | |
0

I have not seen it personally but the same error has been mentioned in a 3.5 year old GeoNet thread:

I rebuilt the dataset and reimported the rasters, checking the box for creating overviews, but I'm still just getting the wire frame. I am also getting error 80042019.

The error sounds random and non-reproducible so all you may be able to do in this instance is to keep updating Esri support on anything you may think relevant about the circumstances in which you see it.

| improve this answer | |
  • This thread was the first hit I got in my original research. I also found that raster loading with xml definitions, and raster property edits can also produce this error. Currently I'm moving a sub set to a local testing environment to see if I can reproduce the issue, then I'll attempt to spot the patterns more closely. – GISI Mar 10 '16 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.