1

At present I have both a shapefile and a CSV file (with coordinates).

When I upload my csv file to QGIS and map the coordinates it takes the following CRS - Selected CRS (EPSG:4326, WGS 84)

When I upload the shapefile - the map which my points should be placed on, the following CRS to shown.

Selected CRS (USER:100000, * Generated CRS (+proj=tmerc +lat_0=53.5 +lon_0=-8 +k=1.000035 +x_0=200000 +y_0=250000 +ellps=mod_airy +towgs84=482.5,-130.6,564.6,-1.042,-0.214,-0.631,8.15 +units=m +no_defs))

The issue is, when I try to join attributes by location, I get a null value - as I imagine the CRS are different. However, when I try to change my CRS to match, both taking (EPSG:4326, WGS 84). The shapefile is moved to some other area (coordinates change).

I have enabled on the fly so I'm not sure what the issue could be?

  • 1
    Could you please clarify the actions you took a bit more? Did you right-click on the shapefile and selected "Set Layer CRS" or how did you tried to change the CRS of your shapefile? According to your explanation the shapefile you're using has a custom CRS, as far as you're not completely sure that it contains WGS84 coordinates, just setting WGS84 as new CRS would not be sufficient. – TobsenB Mar 11 '16 at 11:56
  • Are the CSV coordinates truly latitude-longitude? Are they being imported correctly? latitude = y/northing, longitude = x/easting? – mkennedy Mar 11 '16 at 17:51
  • Welcome to gis.stackexchange! Please edit the title of your question to include enough information for future visitors to be able to find this thread when looking for the same problem. – underdark Mar 13 '16 at 16:35
1

It looks like your .shp file is in TM65 / Irish Grid. You need to set the layer's CRS to EPSG: 29902. (layer properties -> general -> CRS -> select CRS).

The TM65 CRS is in meters, so you can't just tell it that it's in degrees (like WGS 84).

After you've defined the correct CRS, the spatial join should work.

  • I tried the aforementioned steps for a different issue, yet I'm running into trouble. Initially my XY coordinates are set to ESPG 4326, WGS84 and my shapefile is ESPG 29902, TM65/Irish grid. However, when I try to join by location, since the CRS codes don't match I don't get a correct join. To counter this I change my XY CRS to what is used for the shapefile, yet this causes the XY coordinates to move off the map. – Sean O'C Apr 15 '16 at 10:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.