When I input the table in the dialog box, I get this rather long error:

ERROR  updateParameters Execution Error: Runtime error Traceback (most recent call last):
File "c:\program files (x86)\arcgis\desktop10.3\ArcToolbox\Toolboxes\Conversion Tools.tbx#ExcelToTable_conversion.UpdateParameters.py",
    line 4, in 
File "c:\program files (x86)\arcgis\desktop10.3\ArcToolbox\Toolboxes\Conversion Tools.tbx#ExcelToTable_conversion.UpdateParameters.py", 
    line 40, in updateParameters 
File "C:\Program Files (x86)\ArcGIS\Desktop10.3\ArcToolBox\Scripts\ExcelToTable.py",
    line 125, in get_sheet_names workbook = xlrd.open_workbook(in_excel) 
File "C:\Python27\ArcGIS10.3\lib\site-packages\xlrd\__init__.py", 
    line 416, in open_workbook ragged_rows=ragged_rows, 
File "C:\Python27\ArcGIS10.3\lib\site-packages\xlrd\xlsx.py", 
    line 705, in open_workbook_2007_xml ensure_elementtree_imported(verbosity, logfile) 
File "C:\Python27\ArcGIS10.3\lib\site-packages\xlrd\xlsx.py", 
    line 46, in ensure_elementtree_imported ET.iterparse(_dummy_stream) 
File "C:\Python27\ArcGIS10.3\Lib\xml\etree\ElementTree.py", 
    line 1194, in iterparse parser = XMLParser(target=TreeBuilder()) 
File "C:\Python27\ArcGIS10.3\Lib\xml\etree\ElementTree.py", 
    line 1446, in __init__ 
"No module named expat; use SimpleXMLTreeBuilder instead" ImportError: No module named expat; use SimpleXMLTreeBuilder instead

Doing some research, I found here that I might need to upgrade the python. I am new to Python, and I installed 2.7.8 and the tool worked previously. I use Windows 8.1 and it's a 64-bit system. I tried installing the newer python and I got "missing VCRUNTIME140.dll" and I have not found where to fix that yet.

  • 3
    As someone new to Python my advice would be to uninstall/reinstall ArcGIS for Desktop with its Python. The install takes care of all the Python paths etc for you. It may seem like overkill but within 30-45 mins you'll be up and running vs waiting for an answer. – PolyGeo Mar 13 '16 at 21:33
  • 1
    Check your Excel table. ArcGis is very specific about how it wants to see its tables. It must be a 'header row' and values underneath with no extraneous objects. I would think it would be better to save from Excel as CSV and try to import that way. That said though that's an object error.. try switching to the 32 bit (non-background) process as not all libs are available in 64bit before uninstalling/reinstalling. ps. I'd much rather have a long error like that than a short one like "out-of-memory error" which I had to sort out recently.. not even saying what object or line!!! – Michael Stimson Mar 13 '16 at 21:49
  • 2
    If the "the tool worked previously" then you should check that it still works on the same file(s) that it previously worked on. If it does not, then uninstall/reinstall may be appropriate. If it does and it is only a new file that it does not work on then follow @MichaelMiles-Stimson's advice and check your input data. – PolyGeo Mar 13 '16 at 21:54

The uninstall/reinstall (as suggested by PolyGeo) worked.


Alternatively, instead of reinstalling, you can run "repair" from the control panel. worked for me.

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

  • 1
    There's no need for this to be downvoted. "Repair" is perfectly valid response to the condition, and would be faster than an uninstall/re-install cycle. – matt wilkie Nov 20 '17 at 16:52
  • I would have recommended repair installation as well. either one will work but repair is quicker (usually) – NULL.Dude Nov 20 '17 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.