1

Using OS data and CRS of EPSG : 27700 on QGIS, on the new Print Composer how do I get the correct Longitude and latitude scale on the outside of the map? at the moment both scales on the X:Y axis start at 0, not as the actual map states?

4
  • You will need to change your CRS to EPSG:4326 to get latitude and longitude coordinates.
    – Mapperz
    Mar 14, 2016 at 14:21
  • Unfortunately this is not the correct answer, any other help out there?
    – Derek
    Mar 14, 2016 at 17:22
  • Sorry this did not fix the issue.
    – Derek
    Mar 14, 2016 at 17:25
  • Please see iant answer as is it the same method I would do in QGIS composer.
    – Mapperz
    Mar 14, 2016 at 17:42

1 Answer 1

1

You need to change the CRS of your grid (see image below). My map is in OSGB National Grid (epsg:27700) but the grid can be in any projection I like, in this case I've set it to EPSG:4326 which results in the pleasantly curved longitude and latitude lines crossing my map.

For best results I also find it useful to modify the draw coordinates setting to be just latitude on the sides and just longitude on the top and bottom. This avoids confusion where the longitude lines cross the sides of the map.

enter image description here

3
  • I am sorry, but I can only get numbers around the outside of the graph if I put millimetre or centimetres on the interval units, if I put map units I just get one black line through the map, which doesn't give the correct number! Can anyone describe the correct result step by step please? Also I do not want the curved lines, so would prefer to base it on ESPG:27700 if possible.
    – Derek
    Mar 17, 2016 at 15:52
  • If you want the OS Grid references then set the CRS to EPSG:27700 and the interval to 100000 for a 100km grid (anything less will obscure your map if you are looking at the whole country). I just used 4326 because in the question you asked for lat/lon.
    – Ian Turton
    Mar 17, 2016 at 16:00
  • Actually it is not the whole UK, just a portion on 1:40,000 and again on 1: 20,000
    – Derek
    Mar 17, 2016 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.