-1

I am trying to execute clip tool in python on arcGIS 10. But it gives error:

ERROR 000732: Output Extent: Dataset D:/Work/Map/SampleGdb/Sample_02.gdb/Sample_02.gdb/Subcatchments does not exist or is not supported

My code is here:

input1 = r"C:\Users\DELL\AppData\Local\Temp\tempQYJBTS\tempQYJBTS.gdb\IntRaster"
clipG1 = r"D:/Work/Map/SampleGdb/Sample_02.gdb/Sample_02.gdb/Subcatchments"
outRaster1 = "D:/Temp/ClipTest/clip1"
arcpy.Clip_management(input1,"#",outRaster1, clipG1, "#", "ClippingGeometry")

But, I tried the following , and it works fine:

input2 = r"C:\Users\DELL\AppData\Local\Temp\tempQYJBTS\tempQYJBTS.gdb\IntRaster"
clipG2 = r"D:/Temp/Sample_G.gdb/Subcatchments"
outRaster2 = "D:/Temp/ClipTest/clip2"

what is the problem in my first code sample? Does not Path name contains numeric value? Is it ArcGIS rule?

  • This is a common error message so be sure to review gis.stackexchange.com/questions/tagged/error-000732 – PolyGeo Mar 15 '16 at 5:31
  • 2
    So this is FGDB in FGDB where you store subcatchments? Something is terribly wrong with this path – FelixIP Mar 15 '16 at 5:33
  • thanks @ FelixIP ; that was the reason. I have corrected the path like this and it works . clipG1 = r"D:/Work/Map/SampleGdb/Gdb/Sample_02.gdb/Subcatchments" – Monir Mar 15 '16 at 8:14
1

I think the error message gives it away where it says that this pathname does not exist.

D:/Work/Map/SampleGdb/Sample_02.gdb/Sample_02.gdb/Subcatchments

If you really do have a Sample_02.gdb geodatabase inside a Sample_02.gdb geodatabase, then I am sure that will be upsetting the tool.

Instead of:

input1 = r"C:\Users\DELL\AppData\Local\Temp\tempQYJBTS\tempQYJBTS.gdb\IntRaster"
clipG1 = r"D:/Work/Map/SampleGdb/Sample_02.gdb/Sample_02.gdb/Subcatchments"
outRaster1 = "D:/Temp/ClipTest/clip1"

try:

input1 = r"C:\Users\DELL\AppData\Local\Temp\tempQYJBTS\tempQYJBTS.gdb\IntRaster"
clipG1 = "D:/Work/Map/SampleGdb/Sample_02.gdb/Subcatchments"
outRaster1 = "D:/Temp/ClipTest/clip1"

You only need to put r in front of pathnames with single backslashes.

  • Thanks for your quick reply. But same error gives. I have tried your code. – Monir Mar 15 '16 at 5:32
  • @Monir Check the path of clipG1. Do you have a feature class at that path? That's all this issue is. We can only guess as to what your actual path is. – Tom Mar 15 '16 at 6:53
  • thanks for your response. I have corrected the path like this and it works . clipG1 = r"D:/Work/Map/SampleGdb/Gdb/Sample_02.gdb/Subcatchments" – Monir Mar 15 '16 at 8:15
  • Excellent - if you take the r away from this one then I bet it will still work. – PolyGeo Mar 15 '16 at 8:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.