I created an ArcMap document on February 22, 2016. The timestamp, as seen in Windows Explorer, is 2/22/2016 8:58 AM.

I have updated and saved that document many times since, but the timestamp doesn’t change. When I look at the document properties in Windows Explorer, I see that Created (2/22) and Modified (today) are correct, but Accessed is the same as Created, instead of Modified.

This peculiarity affects this MXD only. Other MXDs behave as expected (i.e., "Accessed" matches "Modified"). Any ideas?

I am running ArcGIS Advanced 10.3.1 on Windows 10. The document is stored locally on my C: drive.

I reached out to Esri tech support first, who gave me a superficial, wrong answer. So here I am.


From your post above, it appears that your Created date and Modified dates are correct, just your "Accessed" date seems messed up, correct?

For the short answer, see this SE Superuser post: The last access date is not changed even after reading the file on Windows 7

Turn off NTFS Last Access File Stamp

The NTFS file system updates the "last access" timestamp whenever a file is opened. This time stamp did, on some user machines, cause new or changed files to not appear until an Explorer refresh. Try turning the Last Access stamp off: Open up the registry and go to "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem". Double-click on "NtfsDisableLastAccessUpdate" and set the value from "1" to "0". Now reboot.

For more detail than you want to know, this is actually part of another bug that can cause some of your files to not appear refreshed in Windows Explorer, or even not show up at all. Because you are having this issue, you are likely going to see other issues later on, so I am linking an article to walk through all steps to other potential fixes. This article ("What to do When Windows Explorer Doesn't Refresh") states that it happens from 10-50% of file operations. We hit a point where this would randomly happen to users and a file they were just working on would not show up in their documents. The registry setting change seems to have fixed it for those who were having recurring changes. Copied the list, in case of link breakage. There are more details on how to do all of these in the linked article.

  1. Registry Changes - turn on the Windows desktop refresh feature.
  2. Sort by Name
  3. Re-enable User Account Control
  4. Turn off Third-Party Shell Extensions
  5. Try a Different Firewall/AV solution
  6. Turn off Sharing
  7. Rebuild the Explorer Icon Cache
  8. Turn off NTFS Last Access File Stamp
  9. Uncheck "Show Hidden Files and Folders"
  10. Turn off Home Groups
  11. Restore the Explorer Settings
  12. Delete Libraries

This is not, however, a GIS specific problem, but a Windows issue overall.

  • 1
    I wish I could tell you why it only happens to a small percentage of files and in most cases is not repeatable. Your problem sounds very familiar to some things that I uncovered when researching and fixing some of our file issues, so hopefully this information helps. Drove me crazy digging for answers, and from the Microsoft TechNet links in the article above, file timestamps and directory issues seem to be quite common in Windows 7 and beyond. Good luck! – MaryBeth Mar 15 '16 at 14:49
  • 1
    Created and Accessed are two different fields to display. In Windows Explorer, if you go to View-->Choose Details, you can choose to display one or both timestamps – MaryBeth Mar 15 '16 at 18:36
  • 1
    Correct. By adding "Date modified" I got what I needed. I probably look like an idiot. In my defense I'll say: What is the default "Date" that displays in Windows Explorer without any customization, and why does it display "Created" for some files and "Modified" for others? More or less rhetorical question, to save face ;) – Atanas Entchev Mar 15 '16 at 18:45
  • 1
    No worries. I am 99.9% certain that the default dates in the details have changed in Windows 7 and beyond. – MaryBeth Mar 15 '16 at 19:49
  • 1
    There is no sanity when digging deep into some of these windows issues. I hope this was helpful to you...though it's possible that it's an entirely different issue. – MaryBeth Mar 15 '16 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.