0

I am working with QGIS 2.12.3 Lyon. I have a shapefile which contains slope data for a large territory (layer - PenteSZ32). I want to lighten the weight of my shapefile by clipping it to a narrower surface that correspond to my study area. My study area correspond to a ripperian buffer of 1000 meters (layer - Donut_buffer_1000m). Clipping polygon 1

In order to clip my polygon, i used the Vector > Geoprocessing Tools > Clipper as shown in the following image. This request worked previously with other layers. However, it doensn't work in this case. It bugs at 12 %. Both layer are in the same SCR. Clipping polygon 2

Can you help me figure out what is the problem with my request ? Alternatively, do you have any other way to proceed you could suggest me ?

  • 1
    Do your layers have the same SRC (Right click > Properties > General tab)? – ArMoraer Mar 16 '16 at 14:37
  • I belive that your question is too easy to find if you look for in google. – Diogo Caribé Mar 16 '16 at 14:41
  • @Diogo Caribé i am familliar with the geoprocessing (at least the cliping). However, i was not able to suceed my operation, wich is why i am asking my question here. – Laurent Robitaille-Lainesse Mar 16 '16 at 14:45
  • I fail to see why this should be so heavily downvoted when the OP quite clearly states "i was not able to succesfully clip my polygons". I've seen questions asking how to do basic operations which failed, and those questions were upvoted. @LaurentRobitaille-Lainesse - Perhaps you could upload the 2 shapefiles to a public server so that others could test it? Maybe this will remove some of the negative attention =) – Joseph Mar 17 '16 at 9:56
  • 1
    @Joshep - I left it for a few minutes. I will let it stand for an hour and keep the community in touch. – Laurent Robitaille-Lainesse Mar 17 '16 at 15:45
4

In the menu bar go to Vector > Geoprocessing Tools > Clipper... . Then select as input layer the orange polygon and as clip layer the other one. This should generate a new territory layer which has the dimensions of the turquoise blue one you clipped against.

  • Thank you for your answer. However, i am not able to suceed this operation. The result is blank. I realize i was not clear on my question. I tried this way before. – Laurent Robitaille-Lainesse Mar 16 '16 at 15:05
  • Ok then. Did you already consider ArMoraer's objection? Maybe there's the problem. – TobsenB Mar 16 '16 at 15:29
1

After a few tries, i was able to suceed. You can compare the result before and after in the following images. Both image are at the same scale. I encountered a problem because of these two elements

1) My layer did not had the same SCR

2) I underestimated the amout of time for my computer to process the request

Polygon 1Polygon 2

Here is a little reminder to succeed further operation of this kind

1) Make sure that all of your layers have the same projection (SCR)

2) Make sure you have selected the right layers in your Geoprocessing - Clipping operation

3) Avoid running any unnecessary programs while starting an heavy request

4) Give the software sufficient amount of time

  • 1
    I prefer to do such large tasks on the command line with GDAL ogr2ogr. QGIS does basically the same, but the GUI needs some RAM on its own. See gis.stackexchange.com/questions/151192/… for some performance hints. – AndreJ Mar 17 '16 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.