1

I apologize for posting yet-another-gis-novice's confusion about CRSs, but I have researched the issue and am surprised by what I'm seeing.

In simplest form, I

  • open a new project
  • set On-the-fly (OTF) CRS transformation ON
  • choosing NAD83/Conus Albers (a Projected, and not Geographic CRS) as the Project's CRS (same behavior choosing NAD83/UTM12N)
  • load a 1x1-degree USGS ned30m raster layer which has an assoc. CRS of NAD83 (Geographic CRS)
  • note that the layer comes in "skewed" (a North arrow "decoration" points NNE, about 1-o'clock)
  • note that cursor coordinates appear to be in UTM meters
  • note that the "ruler" distance-measuring tool appears to measure in meters, showing the raster to be approximately 88 x 112 kilometers
  • set raster layer's Layer CRS to NAD83/Conus Albers (to match project's)
  • note that the layer "disappears"
  • note that coordinates of cursor still appear to be UTM meters
  • choose Zoom to that layer
  • note that map is now "squared up" with display (N arrow points N/up)
  • BEFORE moving cursor over map, note that coordinates still appear to be in UTM meters (in "Coordinate:" box at bottom of display)
  • AFTER moving cursor over map, note that the coordinates revert to geographic, Lat and Long
  • after which the "ruler" tool measures the rectangle to be about 1 x 1 (must be degrees again)

As far as I can tell, I have done everything I can to alert QGIS 2.8.6 (similar behavior in 2.14 caused me to try the LTR) to the fact that I prefer meters.

I have also (following other advice I found here) tried Layer->SaveAs (to a Projected CRS), but the resulting 23+GB output hung-up QGIS, causing me to have to abort. (A separate problem owing to my naivete regarding choices I made--or rather, defaults I accepted--in the process of trying to save it.)

This is about as simple an example as I can imagine of wanting, say, to import an elevation file from the USGS and measure the distance around a prominent feature, like a mountain peak, in meters.

Again, I regret my need to broach the subject--again--but I would be deeply appreciative to either find out what I did wrong, or why the behavior I see makes Perfect Sense. Or both.

-- Oertls

Update: The problem is still present in 2.18.23. Project->Properties->CoordDisp is set to MapUnits (automatic), but coords are still displaying in Lat/Long, even though the project CRS is Conus/Albers and the NED layer has been saved-out/reloaded--after relaunching QGIS 2.18--as a Conus/Albers CRS.

However IF I set the NED layer CRS to "NAD83" (its default), coordinates display in meters.

1

In Project -> Project Properties -> General, look out for Coordinate Display.

For some strange reasons, it gets switched to decimal degrees, even when you are working with a projected CRS. It should be set to Map units unless you really want degrees.

You might consider it as bug (http://hub.qgis.org/issues/14319) or a feature...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.