I am using QGIS 2.12.3 Lyon and I want to calculate the area of my polygon in m2. For that I used the tool provided by QGIS, but the result is not as it should be. I got from QGIS 50 ha, while I got from the TopMaps Viewer 20 ha – I know the result from TopMaps Viewer is right, because I have another area with almost the same size, where I already know the area size.

Then I tried to calculate the area by the field calculator and used the formula $area as explained in other questions in the GIS StackExchange (How to calculate polygon areas and perimeters using QGIS? or How to calculate polygon areas in QGIS?). When I try this, I can’t click “ok” and I don’t know why.

Probably I should change the KBS of my shapefile, but I really have a big confusion with that. I am using Google maps as background (EPSG: 3857), my shapefile which I created uses WGS 84, EPSG 4326 and the shapefiles I downloaded from public places uses EPSG 31467 Gauss-Kruger zone 3. Is that a problem? I tried to get them on the same KBS, but then they are at the wrong place. Can that be the problem why the calculation of my area size is wrong?

enter image description here

  • 1
    To click "OK", you need to either create a new field by entering a field name (Ausgabefeldname) or click to update a field (Vorhandenes Feld erneuern).
    – Joseph
    Mar 18, 2016 at 10:24
  • Ohh that was easy. I am sorry, with QGIS I sometimes feel like to face the biggest problem and then it was pretty easy! Thanks a lot to all of you!
    – user68977
    Mar 18, 2016 at 10:30
  • Brilliant, glad you got it working! No need to apologise, everyone always has problems. Please accept @bugmenot123 's answer if it worked for you =)
    – Joseph
    Mar 18, 2016 at 10:33

2 Answers 2


To change the CRS of a layer you must not edit it in its properties but "save as..." and choose the CRS in that dialog. You will get a new file.

In QGIS if you calculate areas it always uses the units of the layer on which you operate. So in your case it tried to calculate some angular area garbage. ;) Save your file as GK3 as well and then use that, you will get square meters.

  • Now I saved my shapefile which i created as GK3, but I still don't get the right area size. I tried it again with the tool that QGIS provides and with the field calculator, but again the button to click "ok" doesn't work. Is the problem the google maps, but actually even with a top 25 it doesn't calculate the right number...
    – user68977
    Mar 18, 2016 at 10:14
  • I have one more question... Why did I had to change the CRS to GK3 and not to for example WGS 84, EPSG 4326? I always thought that WGS 84 is the most common?
    – user68977
    Mar 18, 2016 at 10:32
  • Perfect, thanks a lot! One step closer to understand QGIS :)
    – user68977
    Mar 18, 2016 at 10:58
  • 2
    WGS84 is not popular for display, but as coordinate "storage" system. en.wikipedia.org/wiki/Equirectangular_projection Most maps are projected in something different. On the web usually as 3857. Gauß-Krüger is not a UTM CRS. GK are deprecated and superseded by the UTM CRSs. GK3 ~= UTM 32N (EPSG:25832). Mar 18, 2016 at 11:19

just write the name of your field like "Area_sqm" on the space for "output field name". You will see the "OK" button go active. and make sure that your data is in projected coordinate system so that you will be able to get your area in sqm. I hope this works for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.