2

I import NAD83 latitude/longitude data (EPSG 4269), and the coordinate values displayed are correct. I enable on-the-fly (OTF), then import Google Satellite data, which is automatically WGS84 Pseudo Mercator (EPSG 3857). The coordinate values are corrupted, but the vector overlay looks spatially correct on the Google map.

If I now assign the coordinate system back to NAD83 EPSG 4269, the coordinates for the vector layer are correct, but the Google layer has shifted and will not zoom correctly. I've tried all combinations of loading and assigning datums and all fail. It appears the problem is the Google Pseudo Mercator datum; I tried transforming the vector layer into WGS72 and NAD83 UTM Zone 11 and all was fine. It appears that once a Google layer is imported you are stuck with bad coordinates.

Note I have tried this on QGIS v1.8.0 and 2.14.0 and different operating systems.

  • Not a QGIS user so asking others--is there an odd proj.4 definition of EPSG:3857 in QGIS? I am wondering if you're somehow ending up with the equivalent of EPSG:3395 (World Mercator) rather than true Pseudo Mercator. – mkennedy Mar 18 '16 at 21:20
  • The Google layer is loaded and identified as EPSG:3857 Pseido/Mercator. The vector layer is NAD 83 degrees EPSG:4265 – BWAN Mar 28 '16 at 20:11
2

I'm not super sure what the question you're asking is, but I might suggest using the QuickMapServices plugin and see if you have the same issues. In my experiences QMS works much better than the OpenLayers plugin

  • I looked at the QMS sources and they wre no better. The area is quite remote and not covered well by all sources. – BWAN Mar 28 '16 at 20:11
  • 1
    QMS also has the same Google services as the Openlayers plugin. You have to enable them in the plugin settings with Get Contributed Pack. For licensing issues they are not included by default. – AndreJ Mar 29 '16 at 5:36
1

If you have a shift of about 20km northwards, it is a Pseudo Mercator issue.

Openlayers requires EPSG:3857 as layer and project CRS. The vector layer can have another CRS, like NAD83 degrees. Check Set Layer CRS to see if it is correct, don't use Save As ... in this step.

  • I'm not sure if you are implying a particular sequence for loading layers and setting CRS. The NAD 83 EPSG 4265 layer is loaded first, and OTF set. When the google layer is added the datum is automatically set as combined EPSG 3857, but the coordinates are drastically wrong, however the vector layer looks good - meaning they are pipelines and you can see them correctly overlayed on the image. If I Set Layer CRS to NAD 83 the coordinates are correct on the vector layer, but the Google layer is shifted about 90 m west. – BWAN Mar 28 '16 at 20:11
  • Apart from using QMS, you should start with the project CRS of EPSG:3857. Then load Google imagery, then the vector data. Set the layer CRS so they align. In the Project properties, general tab, you can change the display units between meters and degrees. Remember that EPSG:3857 does not use real meters, they are stretched towards the poles. – AndreJ Mar 29 '16 at 5:40
  • Yes I tried that - set OTF and then EPSG:3857 for Google imagery. I loaded Google (no display since it is effectively global coverage at this point) then loaded the vector NAD83 degrees layer. The area of coverage was correct but coordinates are wrong. With OTF it should transform between either datum. I tried QMS but did not find any decent satellite coverage. BTW - Bing aerial has the same issue as Google. – BWAN Mar 31 '16 at 21:54
  • Just a follow up - when I load the shapefiles into Google Earth Pro they are correct in every sense; location,scale, and coordinate values. I have tried all combinations I can think of for entering the data in QGIS and the coordinates are always corrupted. – BWAN Apr 11 '16 at 20:31
  • Can you give an example pair of lon/lat coordinates, and what values QGIS displays? Did you enable the Contributed Pack in QMS, which provides Google Satellite imagery as well? – AndreJ Apr 12 '16 at 5:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.